Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510496 - openshift_logging_es_pvc_size not honored by openshift-logging playbook
Summary: openshift_logging_es_pvc_size not honored by openshift-logging playbook
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.7.0
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
: 3.7.z
Assignee: Jan Wozniak
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 14:58 UTC by Mike Fiedler
Modified: 2018-01-09 09:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 13:23:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description Mike Fiedler 2017-11-07 14:58:10 UTC
Description of problem:

Version-Release number of the following components:

openshift-ansible.noarch        3.7.0-0.190.0.git.0.129e91a.el7


How reproducible: Always

Deployed logging with inventory below.

openshift_logging_es_pvc_size=100Gi

After deployment all three PVC/PVs were 10Gb

Steps to Reproduce:
1. Deploy logging 3.7.0-0.190.0 using openshift-ansible 3.7.0-0.190.0 with inventory below


Actual results:
openshift_logging_es_pvc_size is not honored.   PVs are 10GB

Expected results:

PVs are 100GB

Additional info:
[OSEv3:vars]
deployment_type=openshift-enterprise

openshift_deployment_type=openshift-enterprise
openshift_release=v3.7
openshift_docker_additional_registries=registry.ops.openshift.com


openshift_logging_install_logging=true
openshift_logging_master_url=https://ec2-34-209-87-198.us-west-2.compute.amazonaws.com:8443
openshift_logging_master_public_url=https://ec2-34-209-87-198.us-west-2.compute.amazonaws.com:8443
openshift_logging_kibana_hostname=kibana.apps.1107-d31.qe.rhcloud.com
openshift_logging_namespace=logging
openshift_logging_image_prefix=registry.ops.openshift.com/openshift3/
openshift_logging_image_version=v3.7
openshift_logging_es_cluster_size=3
openshift_logging_es_pvc_dynamic=true
openshift_logging_es_pvc_size=100Gi
openshift_logging_fluentd_read_from_head=false
openshift_logging_use_mux=true
openshift_logging_use_ops=false

Comment 1 Jan Wozniak 2017-11-10 14:14:22 UTC
the openshift_logging_es_pvc_size was not passed around. This aims to fix it: https://github.com/openshift/openshift-ansible/pull/6088

Comment 2 openshift-github-bot 2017-11-16 13:39:58 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/1c62383d24b775dba46884effc40cc057f5c229d
Bug 1510496 - logging: honor ES PVC size

https://github.com/openshift/openshift-ansible/commit/45532f4578f99243f14493aa42b4ffd7b0fb8265
Merge pull request #6088 from wozniakjan/bug_1510496_es_pvc_size

Automatic merge from submit-queue.

Bug 1510496 - logging: honor ES PVC size

fix for https://bugzilla.redhat.com/show_bug.cgi?id=1510496

Comment 3 Peter Portante 2017-12-01 15:03:48 UTC
Bumping the priority/severity of this bug as this is an operational hazard, causing many resulting problems to fix in ES clusters.

When adding nodes, the cluster becomes unbalanced, with new nodes have 10 Gi PVCs, and existing nodes something larger.

When creating new clusters, the PVCs are created with 10Gi completely ignoring the setting.

Currently the only fix is to recreate them by hand.

Comment 4 Anping Li 2017-12-04 06:21:09 UTC
The pvc are created as expected when use openshift-ansible-3.7.11-1.git.0.42a781f.el7.noarch.  Waiting the bug to errata to verify it.

[root@ip-172-18-6-88 ~]# oc get pvc
NAME               STATUS    VOLUME                                     CAPACITY   ACCESSMODES   STORAGECLASS   AGE
logging-es-0       Bound     pvc-6eb1c39f-d8b8-11e7-9063-0e6b2318521c   8Gi        RWO           gp2            9m
logging-es-1       Bound     pvc-89f19976-d8b8-11e7-9063-0e6b2318521c   8Gi        RWO           gp2            9m
logging-es-2       Bound     pvc-a49255a5-d8b8-11e7-9063-0e6b2318521c   8Gi        RWO           gp2            8m
logging-es-ops-0   Bound     pvc-c207fa39-d8b8-11e7-9063-0e6b2318521c   15Gi       RWO           gp2            7m

Comment 8 errata-xmlrpc 2017-12-18 13:23:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.