Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510463 - After copying an automate item, screen screws up.
Summary: After copying an automate item, screen screws up.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Dmitry Misharov
URL:
Whiteboard:
: 1516010 1516467 (view as bug list)
Depends On:
Blocks: 1514526
TreeView+ depends on / blocked
 
Reported: 2017-11-07 13:10 UTC by Milan Falešník
Modified: 2018-06-21 20:35 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1514526 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:35:12 UTC
Category: Bug
Cloudforms Team: CFME Core
mfalesni: automate_bug+


Attachments (Terms of Use)

Description Milan Falešník 2017-11-07 13:10:00 UTC
Description of problem:
If you copy a class, instance or a method, then after clicking the Copy button, the screen screws up, there is no flash message and buttons don't react. You need to go through main menu again.

The thing gets copied though, so it is just a big inconvenience for the user and for QE.

Version-Release number of selected component (if applicable):
In 5.9, namely 5.9.0.5

How reproducible:
always

Steps to Reproduce:
In description.

Marked with automate_bug as some of our tests copy things around as a prerequisite.

Comment 2 Landon LaSmith 2017-11-10 14:28:17 UTC
I'm still encountering this issue in 5.9.0.8.

Comment 3 Harpreet Kataria 2017-11-16 16:37:29 UTC
https://github.com/ManageIQ/manageiq-ui-classic/pull/2755

Comment 4 CFME Bot 2017-11-17 16:08:57 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/4d33a841869c9a5431beee6e5cb2a90e2468e45e

commit 4d33a841869c9a5431beee6e5cb2a90e2468e45e
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Nov 16 10:50:45 2017 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Nov 17 09:34:21 2017 -0500

    Changed find_by back to find_by_fqname
    
    Issue was introduced in https://github.com/ManageIQ/manageiq-ui-classic/pull/2004, commit c281edf74f2210340535be75718429f467de6709 find_by_fqname was changed to use rails find_by but in this case fqname is not an actual column, find_by_fqname is an actual method in MiqAeNamespace class https://github.com/ManageIQ/manageiq/blob/cb5e0de1766fa363ecfd19715316e17053925d1e/app/models/miq_ae_namespace.rb#L20
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1510463

 app/controllers/miq_ae_class_controller.rb       |  2 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 43 ++++++++++++++++++++++++
 2 files changed, 44 insertions(+), 1 deletion(-)

Comment 6 Greg McCullough 2017-11-22 13:22:33 UTC
*** Bug 1516010 has been marked as a duplicate of this bug. ***

Comment 7 Harpreet Kataria 2017-11-22 17:34:22 UTC
*** Bug 1516467 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.