Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510462 - [HE] Failed to deploy appliance with ERROR: Failed to execute stage 'Environment setup': '_Client' object has no attribute 'list'
Summary: [HE] Failed to deploy appliance with ERROR: Failed to execute stage 'Environm...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: Simone Tiraboschi
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 13:07 UTC by Kobi Hakimi
Modified: 2018-05-23 12:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 08:20:44 UTC
oVirt Team: Integration
mavital: needinfo+
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
ovirt-hosted-engine-setup log file (deleted)
2017-11-07 13:07 UTC, Kobi Hakimi
no flags Details

Description Kobi Hakimi 2017-11-07 13:07:10 UTC
Created attachment 1348955 [details]
ovirt-hosted-engine-setup log file

Description of problem:
[HE] Failed to deploy appliance with ERROR: Failed to execute stage 'Environment setup': '_Client' object has no attribute 'list'


Version-Release number of selected component (if applicable):
rhvm-appliance-4.2-20171102.0

How reproducible:
100%

Steps to Reproduce:
1. Reprovisioned to RHEL: "Red Hat Enterprise Linux Server 7.4 (Maipo)".
2. Installed the appliance: rhev-m appliance: rhvm-appliance-4.2-20171102.0
3. Run the command: hosted-engine --deploy


Actual results:
I failed to deploy this appliance with 
[ ERROR ] Failed to execute stage 'Environment setup': '_Client' object has no attribute 'list'

Expected results:
Run the deployment without errors :)



Additional info:
When I run the deploy command you can see the error below:
[root@puma24 ~]# hosted-engine --deploy
[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          During customization use CTRL-D to abort.
          Continuing will configure this host for serving as hypervisor and create a VM where you have to install the engine afterwards.
          Are you sure you want to continue? (Yes, No)[Yes]: 
          It has been detected that this program is executed through an SSH connection without using screen.
          Continuing with the installation may lead to broken installation if the network connection fails.
          It is highly recommended to abort the installation and run it inside a screen session using command "screen".
          Do you want to continue anyway? (Yes, No)[No]: Yes
[ INFO  ] Hardware supports virtualization
          Configuration files: []
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171106095745-eez99l.log
          Version: otopi-1.7.2_master (otopi-1.7.2-0.0.master.gitf2bfc9c.el7ev)
[ INFO  ] Detecting available oVirt engine appliances
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ ERROR ] Failed to execute stage 'Environment setup': '_Client' object has no attribute 'list'
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20171106095757.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171106095745-eez99l.log
[root@puma24 ~]# 


also you can see the attached log file /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171106095745-eez99l.log:

The error from the log file:
2017-11-06 09:51:50,999+0200 DEBUG otopi.context context._executeMethod:128 Stage late_setup METHOD otopi.plugins.gr_he_setup.vm.runvm.Plugin._late_setup
2017-11-06 09:51:50,999+0200 DEBUG otopi.context context._executeMethod:143 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 133, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/gr-he-setup/vm/runvm.py", line 82, in _late_setup
    response = cli.list()
AttributeError: '_Client' object has no attribute 'list'
2017-11-06 09:51:51,000+0200 ERROR otopi.context context._executeMethod:152 Failed to execute stage 'Environment setup': '_Client' object has no attribute 'list'

Comment 1 Yedidyah Bar David 2017-11-07 13:34:29 UTC
Can you check if it still happens with current master build? I think it's solved by:

https://gerrit.ovirt.org/81404

Comment 2 Yaniv Lavi 2017-11-13 08:47:13 UTC
Can we close this? Is this resolved?

Comment 3 Kobi Hakimi 2017-11-13 10:02:31 UTC
AFAICS this issue still occurs with this appliance(rhvm-appliance-4.2-20171102.0)

as you can see in:
https://rhv-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/rhv-ge-deploy-4.2/478/console

Comment 4 Yedidyah Bar David 2017-11-13 10:09:52 UTC
Fix in comment 1 is in ovirt-hosted-engine-setup, not in the appliance. Please make sure you use the latest ovirt-hosted-engine-setup.

Comment 5 Kobi Hakimi 2017-11-14 08:49:47 UTC
I tried to take the package ovirt-hosted-engine-setup-2.2.0-0.3.master from brew

then updated this package:
http://download.eng.bos.redhat.com/brewroot/packages/ovirt-hosted-engine-setup/2.2.0/0.3.master.git2f7cf9a.el7ev/noarch/ovirt-hosted-engine-setup-2.2.0-0.3.master.git2f7cf9a.el7ev.noarch.rpm
and run the deploy.

but after deploy, we faced this issue https://bugzilla.redhat.com/show_bug.cgi?id=1512534


Note You need to log in before you can comment on or make changes to this bug.