Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510461 - [UI] - use PatternFly alert box for login errors on welcome page
Summary: [UI] - use PatternFly alert box for login errors on welcome page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Greg Sheremeta
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 13:04 UTC by Lucie Leistnerova
Modified: 2017-12-20 11:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-20 11:12:01 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
err_welcome_page (deleted)
2017-11-07 13:04 UTC, Lucie Leistnerova
no flags Details
err_login_page (deleted)
2017-11-07 13:05 UTC, Lucie Leistnerova
no flags Details
fixed (deleted)
2017-11-09 01:30 UTC, Greg Sheremeta
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83815 master MERGED engine: cleanup login and welcome page alerts 2017-11-12 14:38:49 UTC

Description Lucie Leistnerova 2017-11-07 13:04:37 UTC
Created attachment 1348953 [details]
err_welcome_page

Description of problem:
When user is not allowed to perform login to admin or VM portal, error is displayed. But it's only text with no formatting. It should be the same as error on login page.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20171105155215.git59d3324.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. try to log into admin portal with wrong password
2. formatted error displayed, see attachment err_login_page
3. create new user with 
ovirt-aaa-jdbc-tool user add test
ovirt-aaa-jdbc-tool user password-reset test --password=pass:xxx --password-valid-to="2018-01-01 00:00:00Z"
4. in admin portal: Vm detail -> Permissions -> Add, UserRole to user test
5. on welcome page top menu -> Switch user
6. log in with user test
7. user logged in, try to go to admin portal
7. error displayed

Actual results: error is only text, no border, no close button, see attachment err_welcome_page


Expected results: error is formatted as the login page error

Comment 1 Lucie Leistnerova 2017-11-07 13:05:15 UTC
Created attachment 1348954 [details]
err_login_page

Comment 2 Greg Sheremeta 2017-11-09 01:30:01 UTC
Created attachment 1349674 [details]
fixed

Comment 3 Lucie Leistnerova 2017-11-15 17:36:56 UTC
errors on welcome page are now formatted and can be closed

verified in ovirt-engine-4.2.0-0.0.master.20171114111003.git7aa1b91.el7.centos.noarch

Comment 4 Sandro Bonazzola 2017-12-20 11:12:01 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.