Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510450 - Host provisioned/installed with RHEL Workstation OS, after migrating from satellite5 to satellite6 displayed as RHEL server on satellite web Ui
Summary: Host provisioned/installed with RHEL Workstation OS, after migrating from sat...
Keywords:
Status: CLOSED DUPLICATE of bug 1429033
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.2.12
Hardware: Unspecified
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 12:32 UTC by asamad
Modified: 2019-03-06 08:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 08:06:13 UTC


Attachments (Terms of Use)

Description asamad 2017-11-07 12:32:47 UTC
Description of problem:

Satellite server is hosting RHEL Server and Workstation.
client registered with satellite 5 is showing correct OS like RHEL Server and Workstation.
Once the clients which is migrated from satellite5 to satellite6 the OS of RHEL Server views good but OS like Workstation is being viewed as the RHEL server which should not happen.

Clicking Hosts > All hosts > {hostname}, one will see:
* Installed Products > Product: "Red Hat Enterprise Linux Workstation 7.3"
* Content Host Properties > OS: RedHat 7.3    <---- This is what is wrong.




Version-Release number of selected component (if applicable):
Satellite 6.2.12

How reproducible:
Always

Steps to Reproduce:

1. Migrate the RHEL7 Workstation and Server from satellite5 to satellite6.
2. After migration RHEL server OS will be visible as RHEL server.
3. similarly After migration RHEL Workstation OS will also be visible as RHEL server.

Actual results:
After migration RHEL Workstation OS is visible as RHEL server.

Expected results:
After migration RHEL Workstation OS should be visible as RHEL Workstation.

Additional info:
Clients newly provisioned using the satellite6 is not having the issue as there is a workaround present.
Workaround :
In https://access.redhat.com/solutions/3189362, the resolution 1: "Change Settings -> Provisioning -> Ignore facts for operating system-> to true", should turn off assigning the operating system when parsing facts.

Comment 1 Ivan Necas 2017-11-08 13:06:15 UTC

*** This bug has been marked as a duplicate of bug 1429033 ***

Comment 2 asamad 2017-11-09 09:55:02 UTC
Hello Ivan,

This bug is not the duplicate bug of 1429033, because the Bug 1429033 is for newly provisioned machine and in our current customer scenario, customer is having work around for new provisioned machine.

But the customer needs an update or work around for  hosts which is about o be migrated from satellite5 to satellite6.

Comment 3 Ivan Necas 2017-11-09 11:19:47 UTC
In my view, the root cause of both of the bugs is the same. Anyway, hiw are they migrating the clients? Is there domething we could update in the client scripting?

Comment 4 asamad 2017-11-09 14:29:21 UTC
Hello Ivan,

yes the root cause is some what same for both the issue as the clients is workstation which is being migrated from satellite 5 to satellite 6 from where we got this issue.

on satellite 5 there seems to be no issue with the view of workstation as workstation but after migration to satellite 6 the same server is viewed as rhel server which is a bug.

we tried most of the possibilites to update when migrating but did not prove any luck.

If possible kindly provide any workaround.

Comment 5 Ivan Necas 2017-11-09 16:12:55 UTC
There is not a workaround I'm aware of currently. We need to teach the fact parsing how to tell from the facts we are getting, if the OS is server or workstation. One of the problems is, it seems there is no indication of the flavour, in the puppet facts, only the rhsm ones: that's one of the reasons we
have just one RH os, vs. having the workstation and server flavour.

We plan to look into what can be done around this issue //cc Shim.

Comment 7 Bengt Giger 2018-01-03 10:21:41 UTC
Correct data is available. In the host object, fact distribution::name is set to "Red Hat Enterprise Linux Workstation". In the content host object, the installed product shows "Red Hat Enterprise Linux Workstation 6.9". Only in the "Content Host Properties" I see the wrong RHEL Server 6.8, and this wrong data is used for the content host list display.

Comment 8 Marek Hulan 2019-03-06 08:06:13 UTC
This looks as a duplicate of BZ 1429033, please reopen if I misunderstood.

*** This bug has been marked as a duplicate of bug 1429033 ***


Note You need to log in before you can comment on or make changes to this bug.