Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510425 - Time & Date controls in Anaconda still grayed out after disabling Network Time
Summary: Time & Date controls in Anaconda still grayed out after disabling Network Time
Keywords:
Status: MODIFIED
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 11:56 UTC by Maksym Kozub
Modified: 2019-02-19 17:12 UTC (History)
8 users (show)

Fixed In Version: anaconda-30.19-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 19:51:46 UTC


Attachments (Terms of Use)

Description Maksym Kozub 2017-11-07 11:56:01 UTC
Description of problem:
I have recently tried to install Fedora on my Acer Aspire laptops (one of them being ES1-131, the other one ES1-132). See the summary. The problem is actually present in both 26 and 27 Beta (Workstation image in both cases).

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Download a standard Workstation image, prepare a USB stick (using Fedora Media Writer or other image writing software, it doesn't matter; I used both Fedora Media Writer and Rufus).
2. Boot from the USB stick with Fedora image.
3. Click on 'Install to Hard Drive'.
4. In the first Anaconda screen, select the language/keyboard (doesn't matter which one). Click on 'Continue'.
5. Agree to "This is unstable, pre-release software" warning.
6. Click on 'TIME & DATE' (before or after setting 'INSTALLATION DESTINATION', it doesn't matter).
7. In the 'TIME & DATE' screen that appears, click on 'Network Time' button in the top right part (above the timezone map and below the keyboard indicator) to switch it to OFF.

Actual results:
Time (as well as time format, i.e. '24-hour' vs 'AM/PM') and date controls below the map are grayed out. (That said, the timezone map is active and allows to select a timezone.)

Expected results:
Time and date controls become active, allowing the user to set time, time format, and date.

Additional info:
If the user quits Anaconda, launches a terminal session (Utilities->Terminal), types 'sudo anaconda', and repeats the above steps, this time Anaconda's Time & Date screen has the controls in the bottom part active when Network Time is OFF, and grayed out when it is ON, i.e. what seems to be the right behaviour by design.

As a side note, the very fact that in Anaconda's Time & Date spoke Network Time is ON by default setting does not seem logical to me. Look, I start installation in my Acer Aspire ES1-131, which does not even have a network interface at that moment, since Ethernet is not connected, and its BCM4365 Wi-Fi chip is not recognized with free drivers. I believe that whenever a setting results in Fedora going online (like connecting to an NTP server), it should be explicitly marked as such during installation.

I am setting severity to "urgent", since this is a showstopper for a novice user who follows the standard, recommended GUI-based installation procedure. Sorry if I am to harsh with this :).

Comment 1 Maksym Kozub 2017-11-07 13:19:07 UTC
I have just tried Rawhide, and Anaconda behaves in the same way there. Should I change the version to Rawhide for this bug, or should I better keep it as 27, to show that it is present in an "almost stable" pre-release Fedora 27, which is probably more important?

Comment 2 Maksym Kozub 2017-11-22 20:11:03 UTC
Any chance anybody from Anaconda team would pay attention to this one?..

Comment 3 Jiri Konecny 2017-11-23 07:46:15 UTC
Hello,

If it's happening also on Rawhide than I would suggest to switch this to Rawhide. Also logs would be valuable. Could you please attach logs from the installation environment as plain text files. Logs can be found in /tmp/*.log.

Thank you.

Comment 4 Ben Cotton 2018-11-27 17:02:17 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Ben Cotton 2018-11-30 19:51:46 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 6 Vendula Poncova 2019-01-21 18:08:01 UTC
Fixed in the pull request: https://github.com/rhinstaller/anaconda/pull/1773

Comment 7 Ben Cotton 2019-02-19 17:12:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 30 development cycle.
Changing version to '30.


Note You need to log in before you can comment on or make changes to this bug.