Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510406 - "keep_namespace" & "keep_namespace_on_error" should be added while installing ASB
Summary: "keep_namespace" & "keep_namespace_on_error" should be added while installing...
Keywords:
Status: CLOSED DUPLICATE of bug 1511186
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.8.0
Assignee: Fabian von Feilitzsch
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 10:38 UTC by Weihua Meng
Modified: 2017-11-10 01:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-09 19:34:09 UTC


Attachments (Terms of Use)

Description Weihua Meng 2017-11-07 10:38:15 UTC
Description of problem:
"keep_namespace" & "keep_namespace_on_error" should be added while installing ASB

Version-Release number of the following components:
openshift-ansible-3.7.0-0.196.0.git.0.27cd7ec.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. install OCP with ASB
2. check broker-config configmap in openshift-ansible-service-broker project when installation finished
# oc get configmap broker-config -o yaml -n openshift-ansible-service-broker


Actual results:
"keep_namespace" & "keep_namespace_on_error" are not added.

# oc get configmap broker-config -o yaml -n openshift-ansible-service-broker

    openshift:
      host: ""
      ca_file: ""
      bearer_token_file: ""
      sandbox_role: edit
      image_pull_policy: IfNotPresent
    broker:

Expected results:
"keep_namespace" & "keep_namespace_on_error" should be added

openshift:
  host: ""
  ca_file: ""
  bearer_token_file: ""
  image_pull_policy: IfNotPresent
  sandbox_role: "edit"
  keep_namespace: false
  keep_namespace_on_error: true
broker:

https://github.com/openshift/ansible-service-broker/blob/master/etc/example-config.yaml#L34

Additional info:

Comment 4 Weihua Meng 2017-11-09 09:03:29 UTC
Fix in openshift-ansible-3.7.4-1.git.0.254e849.el7.noarch.rpm

Comment 5 John Matthews 2017-11-09 19:34:09 UTC
Note, we ended up fixing this in 3.7 in BZ 1511186

*** This bug has been marked as a duplicate of bug 1511186 ***

Comment 6 Weihua Meng 2017-11-10 01:31:42 UTC
We usually dup new bug to old one.


Note You need to log in before you can comment on or make changes to this bug.