Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510405 - vdo create --indexMem=0 is not accepted anymore
Summary: vdo create --indexMem=0 is not accepted anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vdo
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: bjohnsto
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 10:36 UTC by Jakub Krysl
Modified: 2019-03-06 00:56 UTC (History)
3 users (show)

Fixed In Version: 6.1.0.39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 15:47:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0871 None None None 2018-04-10 15:48:08 UTC

Description Jakub Krysl 2017-11-07 10:36:47 UTC
Description of problem:
According to help/manpage, --indexMem=0 should request default index memory size. 
 This value was accepted in vdo 6.1.0.0-6, but in vdo 6.1.0.34-8 this fails with:
vdo: error: option --indexMem: must be an index memory value

Version-Release number of selected component (if applicable):
vdo 6.1.0.34-8

How reproducible:
100%

Steps to Reproduce:
1.vdo create --device=DEVICE --name=NAME --indexMem=0

Actual results:
vdo: error: option --indexMem: must be an index memory value

Expected results:
vdo created with default index memory value

Additional info:

Comment 3 bjohnsto 2017-11-08 23:18:52 UTC
Have update help and man page to remove the reference to 0. Change should be available in VDO version 38 and greater.

Comment 5 Jakub Krysl 2017-11-14 15:00:50 UTC
Tested with vdo-6.1.0.46-9, both man vdo and vdo --help no longer mention possibility of --indexMem 0.

Comment 8 errata-xmlrpc 2018-04-10 15:47:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0871


Note You need to log in before you can comment on or make changes to this bug.