Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510397 - Compiler atomic built-ins are not correctly detected
Summary: Compiler atomic built-ins are not correctly detected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 10:14 UTC by Xavi Hernandez
Modified: 2018-03-15 11:20 UTC (History)
2 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-15 11:20:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2017-11-07 10:14:22 UTC
Description of problem:

__sync and __atomic built-ins are not correctly detected by configure.ac.

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. ./autogen.sh && ./configure

Actual results:

Macros HAVE_ATOMIC_BUILTINS and HAVE_SYNC_BUILTINS in config.h are not defined, compiling all the code using mutexes instead of atomic operations.

Expected results:

Those macros should be defined if compiler supports them.

Additional info:

Comment 2 Worker Ant 2017-11-07 12:55:14 UTC
REVIEW: https://review.gluster.org/18689 (libglusterfs/atomic: Improved atomic support) posted (#1) for review on master by Xavier Hernandez

Comment 4 Worker Ant 2017-11-14 05:22:32 UTC
COMMIT: https://review.gluster.org/18689 committed in master by \"Xavier Hernandez\" <jahernan@redhat.com> with a commit message- libglusterfs/atomic: Improved atomic support

This patch solves a detection problem in configure.ac that prevented
that compilation detects builtin __atomic or __sync functions.

It also adds more atomic types and support for other atomic functions.

An special case has been added to support 64-bit atomics on 32-bit
systems. The solution is to fallback to the mutex solution only for
64-bit atomics, but smaller atomic types will still take advantage
of builtins if available.

Change-Id: I6b9afc7cd6e66b28a33278715583552872278801
BUG: 1510397
Signed-off-by: Xavier Hernandez <jahernan@redhat.com>

Comment 5 Shyamsundar 2018-03-15 11:20:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.