Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510384 - iSCSI Storage domain's size after executing 'reduceluns' via REST API or 'Remove LUNs' via UI doesn't seem to be updated
Summary: iSCSI Storage domain's size after executing 'reduceluns' via REST API or 'Rem...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: shani
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 10:00 UTC by shani
Modified: 2018-02-12 11:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 11:49:59 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 85861 master MERGED core: Refresh Storage Domain's size after removing LUNs 2018-01-02 16:41:55 UTC

Description shani 2017-11-07 10:00:12 UTC
Description of problem:
After executing on iSCSI storage domain a 'reduceluns' command via REST API, the storage domain's size seems to remain the same, although it should be reduced. 

Version-Release number of selected component (if applicable):
4.2.0

How reproducible:
100%

Steps to Reproduce:
1. create an iSCSI storage domain with some luns.
2. pay attention to the storage doamin's size. 
3. Using the REST API, run the following:

Method:
-------
POST

URL:
----
https://xxxx.xxxx.xxxx.com/ovirt-engine/api/storageDomains/<SD_ID>/reduceluns

Body:
-----
 <action>
   <logical_units>
     <logical_unit id="<LUN_ID>"/>
   </logical_units>
 </action>


Actual results:
Size doesn't seem to be updated - same as before reducing luns.

Expected results:
Size should be reduces.

Additional info:
-

Comment 1 Allon Mureinik 2017-11-08 15:39:09 UTC
When extending a domain, GetVGInfo is called to update the information in the engine after the domain is manipulated on the storage side.

It seems that this isn't done when reducing a domain, and probably should be in order to solve this BZ.
While this isn't a very high priority, it seems like a relatively easy win, and if we intend to expose this action in the GUI, we'd better fix all the GUI hickups.

Comment 2 shani 2018-01-02 10:07:08 UTC
Update Description of problem

Comment 3 Yosi Ben Shimon 2018-01-09 13:23:00 UTC
Tested both via REST API and 'Remove LUNs' via UI.
Both update the size of the SD.

Moving to VERIFIED

Comment 4 Sandro Bonazzola 2018-02-12 11:49:59 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.