Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510376 - Set Containers Volumes as start page not working [NEEDINFO]
Summary: Set Containers Volumes as start page not working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.8.3
Assignee: Nimrod Shneor
QA Contact: Gilad Shefer
URL:
Whiteboard: container
: 1515262 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 09:50 UTC by Gilad Shefer
Modified: 2017-12-05 15:47 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-23 14:10:31 UTC
Category: Bug
Cloudforms Team: Container Management
dajohnso: needinfo? (gshefer)


Attachments (Terms of Use)
Exception screenshot (deleted)
2017-11-07 09:50 UTC, Gilad Shefer
no flags Details
setting page on fine. (deleted)
2017-11-08 16:36 UTC, Nimrod Shneor
no flags Details

Description Gilad Shefer 2017-11-07 09:50:08 UTC
Created attachment 1348895 [details]
Exception screenshot

Description of problem:
When set start page as "Compute / Containers / Volumes" we are getting Unexpected error encountered


Version-Release number of selected component (if applicable):
5.8

How reproducible:
100%


Steps to Reproduce:
1. GoTo: My Settings --> Visual --> Start Page
2. Set Start Page as "Compute / Containers / Volumes"
3. Save.
4. Login again

Actual results:
Unexpected error encountered

Expected results:
We have successfully logged in and our current page is "Compute / Containers / Volumes"


Additional info:

Comment 2 Dave Johnson 2017-11-07 10:03:04 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Nimrod Shneor 2017-11-08 16:35:18 UTC
Gilad, I tried reproducing the bug on fine (5.8.3) and could not find "Compute / Containers / Volumes" option in the Settings page(See screenshot).

Also, on upstream, I did find this option but this seem to work OK.

Which version exactly are you running?

Comment 4 Nimrod Shneor 2017-11-08 16:36:13 UTC
Created attachment 1349536 [details]
setting page on fine.

Comment 5 Nimrod Shneor 2017-11-20 11:09:50 UTC
PR: https://github.com/ManageIQ/manageiq-ui-classic/pull/2769

Comment 6 Nimrod Shneor 2017-11-20 15:50:54 UTC
*** Bug 1515262 has been marked as a duplicate of this bug. ***

Comment 7 Barak 2017-11-20 15:54:53 UTC
PR mentioned in comment #5 is not relevant

The relevant PR is:

https://github.com/ManageIQ/manageiq-ui-classic/pull/2773

Comment 8 Nimrod Shneor 2017-11-23 14:10:31 UTC
According to Himdel (see the PR above), this is not a bug - the intended behavior is that a user's default view is Ems Infra Provider when the db is empty. (The logic here is that there is no point viewing an empty Containers/* list)

The error message shown in the screenshot was caused by a different bug which was fixed in a different PR. (https://github.com/ManageIQ/manageiq-ui-classic/pull/2804/)

Thus this is closed.


Note You need to log in before you can comment on or make changes to this bug.