Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510335 - [UI] - Network's tooltip is missing address, netmask and gateway if the bootproto is dhcp
Summary: [UI] - Network's tooltip is missing address, netmask and gateway if the bootp...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.0
Hardware: x86_64
OS: Linux
medium
low vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 09:13 UTC by Michael Burman
Modified: 2017-12-20 11:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:11:56 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ykaul: blocker-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83684 master MERGED webadmin: Sync attachment Boot protocol and IP info 2017-11-16 13:16:22 UTC

Description Michael Burman 2017-11-07 09:13:32 UTC
Description of problem:
[UI] - Network's tooltip is missing address, netmask and gateway if the bootproto is dhcp.

We have new small regression for the fix done for BZ 1270570, the tooltip is missing the address for networks with bootproto=dhcp, which was ok few weeks ago.

This regression possibly caused by the fix for BZ 1310715

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20171105155215.git59d3324.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Attach network to host via setup networks dialog with bootproto=dhcp and approve operation
2. Hoover with the mouse cursor on top of this network

Actual results:
tooltip is missing address, netmask and gateway

Expected results:
Network's tooltip should show the address, netmask and gateway if network set with bootproto=dhcp as implemented in BZ 1270570

Comment 1 Red Hat Bugzilla Rules Engine 2017-11-07 10:55:51 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Michael Burman 2017-11-19 13:40:54 UTC
Verified on - 4.2.0-0.0.master.20171118160347.git80b3e22.el7.centos

Comment 3 Sandro Bonazzola 2017-12-12 16:11:38 UTC
This bug is targeted 4.2.1 but is verified in 4.2.0.
Can you please check / verify this bug status and set target milestone and bug status accordingly?

Comment 4 Ales Musil 2017-12-14 12:16:45 UTC
It is in 4.2.0

Comment 5 Sandro Bonazzola 2017-12-20 11:11:56 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.