Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510293 - Solution to recover deleted compute node in RHOSP 10
Summary: Solution to recover deleted compute node in RHOSP 10
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Thomas Hervé
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 06:43 UTC by KOSAL RAJ I
Modified: 2019-01-10 06:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 11:46:15 UTC


Attachments (Terms of Use)

Description KOSAL RAJ I 2017-11-07 06:43:46 UTC
Description of problem:
Solution to recover deleted compute node in RHOSP 10

Version-Release number of selected component (if applicable):
RHOSP 10

How reproducible:

The summary of customers action in his environment for the cause of the issue:

1. The customer have taken database backup of the undercloud node.

2. Then he performed one controller replacement. It went success.

3. Then he tried to add a new compute node to the stack and it has failed. The stack was in "UPDATE_FAILED" state
with a nova instance in error.

4. Then he tried removing the node in error state with the command,
openstack overcloud delete node [uuid] (with the exact same template options as the deploy command).

5. All compute node were shut down following this action, and the stack stayed in "UPDATE_IN_PROGRESS" for a few hours before timing out.
You noticed all compute nodes were removed from the openstack server list.

Questions raised to engineers:

1. When the stack was in "UPDATE_FAILED" state, would "openstack overcloud delete node [uuid] (with the exact same template options as
the deploy command)" command will shutdown all the compute and remove from heat stack?

2. Is there a way we can recover all the compute because customer had running instance with customer data?

Note:  very old database from undercloud node is available.
The compute was able to power on but not part of heat stack.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 12 Rabi Mishra 2018-04-11 13:21:22 UTC
Should we close this bug as the customer has recovered and case is closed now?


Note You need to log in before you can comment on or make changes to this bug.