Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510279 - [xfstests xfs/138]: bad xfs_db 'source' command with -c option
Summary: [xfstests xfs/138]: bad xfs_db 'source' command with -c option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xfsprogs
Version: 7.4
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: Zorro Lang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 06:12 UTC by Zorro Lang
Modified: 2018-10-30 11:38 UTC (History)
1 user (show)

Fixed In Version: xfsprogs-4.5.0-16.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:38:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3274 None None None 2018-10-30 11:38:40 UTC

Description Zorro Lang 2017-11-07 06:12:17 UTC
Description of problem:
Report this bug to track the failure of xfs/138 on RHEL-7.

Version-Release number of selected component (if applicable):
RHEL-7.4
xfsprogs-4.5.0-13.el7

How reproducible:
100%

Steps to Reproduce:
1. get xfstests
2. ./check xfs/138

Actual results:
--- /dev/fd/63	2017-11-03 07:34:22.469595614 -0400
+++ results/xfs/138.out.bad	2017-11-03 07:34:22.289595614 -0400
@@ -1,8 +1,6 @@
 QA output created by 138
 Test with -c
 magicnum = XFS_MAGIC
-This is file A 
-This is file B 
 magicnum = XFS_MAGIC
 Test with interactive
 magicnum = XFS_MAGIC

Expected results:
xfs/138 test pass

Additional info:
I think it's fixed on upstream xfsprogs v4.10 with:
commit c8dc4235614292020f82a031545d66c000b455f9
Author: Darrick J. Wong <darrick.wong@oracle.com>
Date:   Wed Jan 25 20:02:43 2017 -0600

    xfs_db: fix the 'source' command when passed as a -c option

Comment 4 errata-xmlrpc 2018-10-30 11:38:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3274


Note You need to log in before you can comment on or make changes to this bug.