Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510105 - stomp.py 3.1.6 doesn't support IPv6
Summary: stomp.py 3.1.6 doesn't support IPv6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: stomppy
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 17:21 UTC by Darko Lukic
Modified: 2017-11-25 05:14 UTC (History)
2 users (show)

Fixed In Version: stomppy-3.1.6-3.el7 stomppy-3.1.6-2.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-25 04:11:46 UTC


Attachments (Terms of Use)
IPv6 support patch (deleted)
2017-11-06 17:21 UTC, Darko Lukic
no flags Details | Diff

Description Darko Lukic 2017-11-06 17:21:40 UTC
Created attachment 1348694 [details]
IPv6 support patch

Description of problem:
Existing version of stomp.py package (3.1.6) doesn't support IPv6.

Version-Release number of selected component (if applicable):
3.1.6


How reproducible:
conn = stomp.Connection([(some_ipv6_address, 61616)], 'user', 'pass')
conn.start()
conn.connect(wait=True)
conn.send(message='HelloWorld', destination='/topic/helloworld')


Actual results:
"WARNING:stomp.py:Could not connect to host #IP#, port #port#: [Errno -9] Address family for hostname not supported"

Additional info:
Patch is available as an attachment.

Comment 1 Steve Traylen 2017-11-08 12:17:42 UTC
Do you have a link to the upstream commit. I realise you had to rework it to isolate this one thing.

Comment 2 Darko Lukic 2017-11-08 13:09:06 UTC
Here is a commit:
https://github.com/jasonrbriggs/stomp.py/commit/bf678a204f56ddd99ae3f26fbb386dd1205e63e0
However, those are changes on top of version 4.1.5 (check a parent commit: 0444dc7). 

In the given commit (bf678a204) they introduced compatibility layer for Python 2.5 and Python 2.6+. The patch is made by extracting only changes from compatibility layer for Python 2.6+.

Comment 3 Fedora Update System 2017-11-09 01:46:34 UTC
stomppy-3.1.6-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-eb67f4aebb

Comment 4 Fedora Update System 2017-11-09 02:07:35 UTC
stomppy-3.1.6-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-ce93b28876

Comment 5 Fedora Update System 2017-11-25 04:11:46 UTC
stomppy-3.1.6-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2017-11-25 05:14:12 UTC
stomppy-3.1.6-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.