Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510056 - [UPDATES] OC update failed: Error EINVAL: specified pgp_num 128 > pg_num 32
Summary: [UPDATES] OC update failed: Error EINVAL: specified pgp_num 128 > pg_num 32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-ceph
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z6
: 10.0 (Newton)
Assignee: Sofer Athlan-Guyot
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks: 1510975
TreeView+ depends on / blocked
 
Reported: 2017-11-06 16:06 UTC by Yurii Prokulevych
Modified: 2017-11-15 13:47 UTC (History)
13 users (show)

Fixed In Version: puppet-ceph-2.4.1-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1510975 (view as bug list)
Environment:
Last Closed: 2017-11-15 13:47:19 UTC
scohen: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1730457 None None None 2017-11-06 17:20:56 UTC
Red Hat Product Errata RHBA-2017:3231 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-11-15 18:36:45 UTC
OpenStack gerrit 518325 None None None 2017-11-07 15:07:10 UTC

Description Yurii Prokulevych 2017-11-06 16:06:43 UTC
Description of problem:
-----------------------
Minor update of RHOS-10(rhel_7.4_update) to z6 failed:
openstack stack failures list overcloud

overcloud.AllNodesDeploySteps.ControllerDeployment_Step4.1:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: 61bfa6f1-f646-4614-a371-abb0a73fd222
  status: UPDATE_FAILED
  status_reason: |
    UPDATE aborted
  deploy_stdout: |
    ...
    Debug: Using settings: adding file resource 'rrddir': 'File[/var/lib/puppet/rrd]{:path=>"/var/lib/puppet/rrd", :mode=>"750", :owner=>"puppet", :group=>"puppet", :ensure=>:directory, :loglevel=>:debug, :links
=>:follow, :backup=>false}'
    Debug: /File[/var/lib/puppet/rrd]/seluser: Found seluser default 'system_u' for /var/lib/puppet/rrd
    Debug: /File[/var/lib/puppet/rrd]/selrole: Found selrole default 'object_r' for /var/lib/puppet/rrd
    Debug: /File[/var/lib/puppet/rrd]/seltype: Found seltype default 'puppet_var_lib_t' for /var/lib/puppet/rrd
    Debug: /File[/var/lib/puppet/rrd]/selrange: Found selrange default 's0' for /var/lib/puppet/rrd
    Debug: Finishing transaction 283874100
    Debug: Received report to process from controller-1.localdomain
    Debug: Evicting cache entry for environment 'production'
    Debug: Caching environment 'production' (ttl = 0 sec)
    Debug: Processing report from controller-1.localdomain with processor Puppet::Reports::Store
    (truncated, view all with --long)
  deploy_stderr: |
    thout storeconfigs
    Warning: Not collecting exported resources without storeconfigs
    Warning: Not collecting exported resources without storeconfigs
overcloud.AllNodesDeploySteps.ControllerDeployment_Step4.2:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: e92bcc00-f9ae-4fc2-a9be-20d1e90d2655
  status: UPDATE_FAILED
  status_reason: |
    Error: resources[2]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6
  deploy_stdout: |
    ...
    Debug: Using settings: adding file resource 'rrddir': 'File[/var/lib/puppet/rrd]{:path=>"/var/lib/puppet/rrd", :mode=>"750", :owner=>"puppet", :group=>"puppet", :ensure=>:directory, :loglevel=>:debug, :links
=>:follow, :backup=>false}'
    Debug: /File[/var/lib/puppet/rrd]/seluser: Found seluser default 'system_u' for /var/lib/puppet/rrd
    Debug: /File[/var/lib/puppet/rrd]/selrole: Found selrole default 'object_r' for /var/lib/puppet/rrd
    Debug: /File[/var/lib/puppet/rrd]/seltype: Found seltype default 'puppet_var_lib_t' for /var/lib/puppet/rrd
    Debug: /File[/var/lib/puppet/rrd]/selrange: Found selrange default 's0' for /var/lib/puppet/rrd
    Debug: Finishing transaction 273410780
    Debug: Received report to process from controller-2.localdomain
    Debug: Evicting cache entry for environment 'production'
    Debug: Caching environment 'production' (ttl = 0 sec)
    Debug: Processing report from controller-2.localdomain with processor Puppet::Reports::Store
    (truncated, view all with --long)
  deploy_stderr: |
    p_num 128 returned 22 instead of one of [0]
    Warning: /Firewall[998 log all]: Skipping because of failed dependencies
    Warning: /Firewall[999 drop all]: Skipping because of failed dependencies



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
libcephfs1-10.2.7-48.el7cp.x86_64
ceph-osd-10.2.7-48.el7cp.x86_64
ceph-radosgw-10.2.7-48.el7cp.x86_64
puppet-ceph-2.3.0-7.el7ost.noarch
ceph-base-10.2.7-48.el7cp.x86_64
ceph-selinux-10.2.7-48.el7cp.x86_64
python-cephfs-10.2.7-48.el7cp.x86_64
ceph-common-10.2.7-48.el7cp.x86_64
ceph-mon-10.2.7-48.el7cp.x86_64

puppet-ceph-2.3.0-7.el7ost.noarch (undercloud)

How reproducible:
-----------------


Steps to Reproduce:
1. Install RHOS-10 rhel_7.4_update with RHEL-7.4
2. Install z6 repos on uc oc
3. Apply patch on uc - https://review.openstack.org/#/c/517356/
4. Update UC
5. Follow procedure to update oc (update deployment plan/run update)


Actual results:
---------------
Update failed

Expected results:
-----------------
OC is successfully updated

Additional info:
----------------
Virtual setup: 3controllers + 2computes + 3ceph

Comment 2 Giulio Fidente 2017-11-06 16:48:14 UTC
Until z6 pg_num and pgp_num defaulted to 32, instead of 128.

The problem is that puppet-ceph tries to set new pgp_num values after pg_num is set, we need a require rule on pg_num instead.

As a workaround one might use the pre-existing values:

parameter_defaults:
  ExtraConfig:
    ceph::profile::params::osd_pool_default_pg_num: 32
    ceph::profile::params::osd_pool_default_pgp_num: 32

Comment 3 Giulio Fidente 2017-11-06 16:50:06 UTC
> The problem is that puppet-ceph tries to set new pgp_num values after pg_num
> is set, we need a require rule on pg_num instead.

this was puppet-ceph tries to set the new pgp_num values *before* pg_num is set

Comment 9 Yogev Rabl 2017-11-10 13:02:08 UTC
Verified

Comment 11 errata-xmlrpc 2017-11-15 13:47:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3231


Note You need to log in before you can comment on or make changes to this bug.