Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510053 - CFME with RHV Graph refresh turned ON - RHV Datastores are displayed multiple times.
Summary: CFME with RHV Graph refresh turned ON - RHV Datastores are displayed multiple...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.10.0
Assignee: Piotr Kliczewski
QA Contact: Angelina Nikiforova
URL:
Whiteboard: rhev:graph refresh
Depends On:
Blocks: 1532255 1514217 1514246
TreeView+ depends on / blocked
 
Reported: 2017-11-06 16:02 UTC by Ilanit Stein
Modified: 2019-04-02 08:23 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1514217 1514246 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:07:09 UTC
Category: Bug
Cloudforms Team: RHEVM


Attachments (Terms of Use)
cfmelog_graph_refresh_on.zip (deleted)
2017-11-06 16:07 UTC, Ilanit Stein
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1528859 None None None Never
Github ManageIQ manageiq pull 16408 None None None 2017-11-07 14:52:37 UTC

Internal Links: 1528859

Description Ilanit Stein 2017-11-06 16:02:17 UTC
Description of problem:
ON CFME+RHV Graph refresh turned ON (It is off by default),
"All Datastores" are displayed multiple times.
Important to mention that this is not about CFME saving history.
2 RHV providers were added, and or both same problem occurred.
The problem is seen right after adding the RHV provider.   

Version-Release number of selected component (if applicable):
CFME-5.9.0.4/RHV-4.1.7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Same RHV provider, connected to CFME-5.9.0.4 do not have this issue.

Comment 2 Ilanit Stein 2017-11-06 16:07:06 UTC
Created attachment 1348662 [details]
cfmelog_graph_refresh_on.zip

Comment 3 Piotr Kliczewski 2017-11-07 12:04:24 UTC
I tested this using graph refresh by adding the engine it was used to find this bug and I can see the duplicates. When I inspected db I can see one Storage entity per storage domain. When testing it with regular refresh I noticed that "All Datastores" contains the duplicates.

This bug is not related to graph refresh and should not block the feature.

Comment 4 Piotr Kliczewski 2017-11-07 14:24:56 UTC
After each refresh datastores are growing when using graph refresh. Investigating main cause of it.

Comment 5 Adam Grare 2017-11-15 19:12:36 UTC
This should have been resolved by https://github.com/ManageIQ/manageiq/pull/16408


Note You need to log in before you can comment on or make changes to this bug.