Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510042 - [abrt] systemd-udev: __libc_open64(): systemd-udevd killed by SIGABRT
Summary: [abrt] systemd-udev: __libc_open64(): systemd-udevd killed by SIGABRT
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:96e49c48b716d1ed6b45240cb58...
: 1515345 1520506 1541000 1575310 1593831 1599326 1599328 1599330 1601247 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 15:20 UTC by Luís Silva
Modified: 2019-01-14 21:33 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-28 14:22:54 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: cgroup (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: core_backtrace (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: cpuinfo (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: dso_list (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: environ (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: limits (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: maps (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: open_fds (deleted)
2017-11-06 15:20 UTC, Luís Silva
no flags Details
File: proc_pid_status (deleted)
2017-11-06 15:21 UTC, Luís Silva
no flags Details
File: var_log_messages (deleted)
2017-11-06 15:21 UTC, Luís Silva
no flags Details

Description Luís Silva 2017-11-06 15:20:40 UTC
Version-Release number of selected component:
systemd-udev-234-8.fc27

Additional info:
reporter:       libreport-2.9.2
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-udevd
crash_function: __libc_open64
executable:     /usr/lib/systemd/systemd-udevd
journald_cursor: s=93e53034493748d1ae4c3f434d6b8cb8;i=18cf;b=cb2f33c1f0a34390846a6bcf970c7b9b;m=39334cdb4;t=55d50e055e481;x=e0888c5a5ac8bcee
kernel:         4.13.9-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (9 frames)
 #0 __libc_open64 at ../sysdeps/unix/sysv/linux/open64.c:46
 #1 open64 at /usr/include/bits/fcntl2.h:53
 #2 synthesize_change at ../src/udev/udevd.c:1043
 #3 on_inotify at ../src/udev/udevd.c:1152
 #4 source_dispatch at ../src/libsystemd/sd-event/sd-event.c:2272
 #5 sd_event_dispatch at ../src/libsystemd/sd-event/sd-event.c:2631
 #6 sd_event_run at ../src/libsystemd/sd-event/sd-event.c:2690
 #7 sd_event_loop at ../src/libsystemd/sd-event/sd-event.c:2710
 #8 run at ../src/udev/udevd.c:1643

Comment 1 Luís Silva 2017-11-06 15:20:46 UTC
Created attachment 1348641 [details]
File: backtrace

Comment 2 Luís Silva 2017-11-06 15:20:48 UTC
Created attachment 1348642 [details]
File: cgroup

Comment 3 Luís Silva 2017-11-06 15:20:49 UTC
Created attachment 1348643 [details]
File: core_backtrace

Comment 4 Luís Silva 2017-11-06 15:20:51 UTC
Created attachment 1348644 [details]
File: cpuinfo

Comment 5 Luís Silva 2017-11-06 15:20:52 UTC
Created attachment 1348645 [details]
File: dso_list

Comment 6 Luís Silva 2017-11-06 15:20:54 UTC
Created attachment 1348646 [details]
File: environ

Comment 7 Luís Silva 2017-11-06 15:20:55 UTC
Created attachment 1348647 [details]
File: limits

Comment 8 Luís Silva 2017-11-06 15:20:57 UTC
Created attachment 1348648 [details]
File: maps

Comment 9 Luís Silva 2017-11-06 15:20:59 UTC
Created attachment 1348649 [details]
File: open_fds

Comment 10 Luís Silva 2017-11-06 15:21:00 UTC
Created attachment 1348650 [details]
File: proc_pid_status

Comment 11 Luís Silva 2017-11-06 15:21:02 UTC
Created attachment 1348651 [details]
File: var_log_messages

Comment 12 Zbigniew Jędrzejewski-Szmek 2018-03-28 14:18:12 UTC
*** Bug 1520506 has been marked as a duplicate of this bug. ***

Comment 13 Zbigniew Jędrzejewski-Szmek 2018-03-28 14:22:54 UTC
#0  0x00007f5cacc4bf6e in __libc_open64 (file=0x55ed415c1650 "/dev/sdb", oflag=<optimized out>) at ../sysdeps/unix/sysv/linux/open64.c:46
46	  return SYSCALL_CANCEL (openat, AT_FDCWD, file, oflag | EXTRA_OPEN_FLAGS,

Thread 1 (Thread 0x7f5cad03e9c0 (LWP 13078)):
#0  0x00007f5cacc4bf6e in __libc_open64 (file=0x55ed415c1650 "/dev/sdb", oflag=<optimized out>) at ../sysdeps/unix/sysv/linux/open64.c:46
        resultvar = 17
        mode = <optimized out>
#1  0x000055ed40f0133a in open64 () at /usr/include/bits/fcntl2.h:53
No locals.

It looks like udevd is killed by the watchdog while it's waiting for a disk device to respond. There isn't much we can do in such a case. There should be no effect from this, just udevd being restarted.

Comment 14 Clemens Eisserer 2018-06-02 07:31:52 UTC
Similar problem has been detected:

systemd crashed while in background

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-udevd
crash_function: __libc_open64
executable:     /usr/lib/systemd/systemd-udevd
journald_cursor: s=e4a0bf050fad4203bcebb813973dfed6;i=55624;b=93ec5c46aaa44d058fbc4595a40c9c57;m=506183fa2;t=56d5759fbf858;x=f8dd672e22b2b3be
kernel:         4.16.11-200.fc27.x86_64
package:        systemd-udev-234-11.git5f8984e.fc27
reason:         systemd-udevd killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 15 Clemens Eisserer 2018-06-02 07:33:12 UTC
I quite regulary see this during shutdown - some systemd operations/services are pending and delay system shutdown until they time out. rather annoying.

Comment 16 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:20:15 UTC
*** Bug 1572915 has been marked as a duplicate of this bug. ***

Comment 17 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:20:24 UTC
*** Bug 1575310 has been marked as a duplicate of this bug. ***

Comment 18 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:20:36 UTC
*** Bug 1599326 has been marked as a duplicate of this bug. ***

Comment 19 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:20:48 UTC
*** Bug 1599328 has been marked as a duplicate of this bug. ***

Comment 20 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:20:59 UTC
*** Bug 1599330 has been marked as a duplicate of this bug. ***

Comment 21 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:21:10 UTC
*** Bug 1601247 has been marked as a duplicate of this bug. ***

Comment 22 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:21:22 UTC
*** Bug 1589413 has been marked as a duplicate of this bug. ***

Comment 23 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:21:33 UTC
*** Bug 1593831 has been marked as a duplicate of this bug. ***

Comment 24 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:21:45 UTC
*** Bug 1515345 has been marked as a duplicate of this bug. ***

Comment 25 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:21:58 UTC
*** Bug 1576356 has been marked as a duplicate of this bug. ***

Comment 26 Zbigniew Jędrzejewski-Szmek 2018-07-18 11:42:14 UTC
*** Bug 1541000 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.