Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510035 - [RFE] Nodes tagging : better match nova flavors and ironic profiles in UI [NEEDINFO]
Summary: [RFE] Nodes tagging : better match nova flavors and ironic profiles in UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M1
: 14.0 (Rocky)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 15:08 UTC by Ola Pavlenko
Modified: 2019-01-11 11:49 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-ui-9.3.1-0.20180909174557.1a18ba7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:48:21 UTC
jamsmith: needinfo? (jtomasek)


Attachments (Terms of Use)
controller flavor (deleted)
2017-11-06 15:08 UTC, Ola Pavlenko
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:49:03 UTC
OpenStack gerrit 542908 None None None 2018-08-07 14:57:15 UTC
OpenStack gerrit 545098 None None None 2018-08-07 14:57:36 UTC

Description Ola Pavlenko 2017-11-06 15:08:04 UTC
Created attachment 1348638 [details]
controller flavor

Description of problem:
Using custom profiles, node that tagged with profile X wan't assigned to a role with the same profile. Role counter wasn't updated.

Version-Release number of selected component (if applicable):

openstack-tripleo-ui-7.4.2-2.el7ost.noarch
How reproducible:
always

Steps to Reproduce:
1. via UI, create a custom profile
2. tag a node with the custom profile
3. on deployment page, edit a roles flavor to match the custom profile

Actual results:
roles counter for # of assigned nodes to the role (with matching flavor) is not updated. 

Expected results:
node tagged with the custom profile should be assigned to the role with matching profile. roles counter for # assigned nodes to the role was updated.

Additional info:

Comment 3 Jiri Tomasek 2017-11-15 13:01:25 UTC
Note that this is currently expected behaviour. Tagging the node does not explicitly mark the node for deployment. It just means that in case it gets deployed, it is going to be used for a role which profile matches the tagged profile of the node.

Nodes are added for deployment by specifying the count on deployment page. This is completely separate step and IMHO it is a good thing -> user does not always want to deploy all the nodes available.

Comment 4 Beth Elwell 2017-11-28 15:25:42 UTC
Hi Jiri,

Can you clarify from your above comment: is this therefore an unwanted feature that should be closed or is there a way to complete this RFE while keeping desired behaviours?

Thanks,
Beth

Comment 6 Jiri Tomasek 2017-11-28 15:30:52 UTC
IMHO this is unwanted feature as, as described above, the nodes tagging and assignment are two separate steps on purpose.

Comment 18 Udi 2018-10-23 07:09:49 UTC
Verified. The UI now checks for the roles with the profile that's configured as the flavor of the role (instead of just expecting the flavor name to always be the role name). The only known limitation is that the GUI expects the flavors' profiles to always be the same as the flavors' names.

Comment 21 errata-xmlrpc 2019-01-11 11:48:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.