Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509986 - Killing nautilus two times causes session crash
Summary: Killing nautilus two times causes session crash
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-session
Version: 7.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1696694
TreeView+ depends on / blocked
 
Reported: 2017-11-06 14:03 UTC by Martin Krajnak
Modified: 2019-04-05 12:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1696694 (view as bug list)
Environment:
Last Closed: 2018-06-27 07:58:36 UTC


Attachments (Terms of Use)
full journalctl log (deleted)
2017-11-06 14:03 UTC, Martin Krajnak
no flags Details
backtrace from gdb attached to imsettings deamon plog (deleted)
2017-11-06 14:04 UTC, Martin Krajnak
no flags Details

Description Martin Krajnak 2017-11-06 14:03:24 UTC
Created attachment 1348598 [details]
full journalctl log

Description of problem:
Executing 'pkill nautilus' two times in a row crashes the gnome session and leads to gdm loading screen

Version-Release number of selected component (if applicable):
gnome-shell-3.26.2-1.el7.x86_64
imsettings-1.6.3-9.el7.x86_64
ibus-1.5.17-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Open terminal and execute
2.pkill nautilus
3.pkill nautilus

Actual results:
First execution:
Desktop icons are gone for a split second.
Second execution:
Session crashed, user is logged out.

Expected results:
User should not be logged out. Gnome session should keep running without crashes.

Additional info:
part of log ( full log in attachment) imsettings shutdown

Nov 06 14:59:41 localhost.localdomain gnome-session-binary[1402]: WARNING: Application 'nautilus-classic.desktop' killed by signal 15
Nov 06 14:59:41 localhost.localdomain gnome-session-binary[1402]: Unrecoverable failure in required component nautilus-classic.desktop
Nov 06 14:59:41 localhost.localdomain gnome-session[1402]: gnome-session-binary[1402]: WARNING: Application 'nautilus-classic.desktop' killed by signal 15
Nov 06 14:59:41 localhost.localdomain gnome-session[1402]: gnome-session-binary[1402]: WARNING: App 'nautilus-classic.desktop' respawning too quickly
Nov 06 14:59:41 localhost.localdomain gnome-session-binary[1402]: WARNING: App 'nautilus-classic.desktop' respawning too quickly
Nov 06 14:59:41 localhost.localdomain gnome-session-f[2628]: Cannot open display: 
Nov 06 14:59:42 localhost.localdomain gdm-autologin][1373]: pam_unix(gdm-autologin:session): session closed for user test
Nov 06 14:59:42 localhost.localdomain evolution-calen[2256]: e_intervaltree_destroy: assertion 'E_IS_INTERVALTREE (tree)' failed
Nov 06 14:59:42 localhost.localdomain com.redhat.imsettings[1410]: [ 1509976782.081792]: IMSettings-Daemon[1490]: INFO: Release the ownership of com.redhat.imsettings
Nov 06 14:59:42 localhost.localdomain com.redhat.imsettings[1410]: Exiting...
Nov 06 14:59:42 localhost.localdomain com.redhat.imsettings[1410]: [ 1509976782.081925]: GLib-GIO[1490]: CRITICAL **: Error while sending AddMatch() message: The connection is closed
Nov 06 14:59:42 localhost.localdomain com.redhat.imsettings[1410]: [ 1509976782.081980]: GLib-GIO[1490]: CRITICAL **: Error while sending AddMatch() message: The connection is closed
Nov 06 14:59:42 localhost.localdomain com.redhat.imsettings[1410]: [ 1509976782.082037]: IMSettings-Daemon[1490]: INFO: Unloading imesttings module: gsettings
Nov 06 14:59:42 localhost.localdomain com.redhat.imsettings[1410]: [ 1509976782.082091]: IMSettings-Daemon[1490]: INFO: imsettings-daemon is shut down.

Comment 2 Martin Krajnak 2017-11-06 14:04:56 UTC
Created attachment 1348599 [details]
backtrace from gdb attached to imsettings deamon plog

Comment 3 Akira TAGOH 2017-11-06 14:15:01 UTC
Nov 06 14:59:41 localhost.localdomain gnome-session-binary[1402]: WARNING: App 'nautilus-classic.desktop' respawning too quickly

IMHO The above log says it all though, I'll leave it to the gnome-session maintainer. I'll comment for imsettings only.

Why you saw the log of the shutdown of imsettings is because the parent session of dbus is closed. which held by gnome-session. so from POV of imsettings, that behavior is correct.

reassigning to gnome-session to see the comment for my guess.

Comment 4 Ray Strode [halfline] 2017-11-06 15:49:35 UTC
normally we'd show fail whale but it can't find the DISPLAY:

Nov 06 14:59:41 localhost.localdomain gnome-session-f[2628]: Cannot open display:

Comment 5 Martin Krajnak 2018-06-27 07:58:36 UTC
Not reproducible with:

gnome-session-3.28.1-2.el7.x86_64
nautilus-3.26.3.1-2.el7.x86_64


Note You need to log in before you can comment on or make changes to this bug.