Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509973 - fonts/everything profile installation fails because of missing dependencies
Summary: fonts/everything profile installation fails because of missing dependencies
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-modular-release
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Irina Gulina
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: ModularServer27GA F27ServerBetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-11-06 13:41 UTC by Irina Gulina
Modified: 2017-11-14 20:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 20:03:41 UTC


Attachments (Terms of Use)
module install fonts/everything logs (deleted)
2017-11-09 09:48 UTC, Irina Gulina
no flags Details

Description Irina Gulina 2017-11-06 13:41:13 UTC
Description of problem:
fonts/everything profile installation fails on Fedora-Modular-27-20171106.n.0 because of missing dependencies. 

Actual results:
fonts/everything => 

Problem 1: conflicting requests  - nothing provides mono(mscorlib) = 4.0.0.0 needed by sharpfont-4.0.1-4.module_bedbd3b3.x86_64

Problem 2: conflicting requests  - nothing provides perl(GD) needed by unifont-9.0.06-4.module_bedbd3b3.x86_64

Problem 3: conflicting requests  - nothing provides python3-pyxdg needed by fonts-tweak-tool-0.3.2-15.module_bedbd3b3.x86_64

Problem 4: conflicting requests  - nothing provides texlive-base needed by tex-fonts-hebrew-0.1-26.module_bedbd3b3.noarch

Problem 5: conflicting requests  - nothing provides gnome-shell needed by gnome-shell-extension-ibus-font-0.20170217-2.module_bedbd3b3.noarch

Problem 6: conflicting requests  - nothing provides liballeg.so.4.4()(64bit) needed by alfont-2.0.9-12.module_bedbd3b3.x86_64

Problem 7: package fonttools-3.14.0-1.module_bedbd3b3.noarch requires python3-fonttools, but none of the providers can be installed  - conflicting requests  - nothing provides python3-numpy needed by python3-fonttools-3.14.0-1.module_bedbd3b3.noarch

Problem 8: package urw-base35-fonts-20170801-2.module_bedbd3b3.noarch obsoletes urw-fonts < 3:2.4-25 provided by urw-fonts-3:2.4-24.module_bedbd3b3.noarch  - conflicting requests

[1] https://ci.centos.org/job/fedora-qa-compose-tests/135/artifact/compose-tests/mod_install_results.log
[2] https://ci.centos.org/job/fedora-qa-compose-tests/135/artifact/compose-tests/error.log


Additional info:

Comment 1 Stephen Gallagher 2017-11-06 16:19:58 UTC
Please explain what you are actually doing that results in these conflicts. We can't reproduce and fix it if we don't know what's going wrong.

I suspect the problem is that we have two modules providing conflicting versions of the same font, though. CCing Karsten.

Comment 2 Fedora Blocker Bugs Application 2017-11-06 16:21:42 UTC
Proposed as a Freeze Exception for 27-server-beta by Fedora user sgallagh using the blocker tracking app because:

 We should really make sure that fonts aren't conflicting with one another in the release.

Comment 3 Karsten Hopp 2017-11-06 16:32:30 UTC
The problem is that I've included all the fonts in the 'everything' profile without checking if they have additional requirements.
The fix for this is to remove those fonts from the profile (after cross checking with langtable.xml so that we don't accidentally remove fonts required by anaconda)
I've already done that and it looks like all of them are save to remove from the profile.

Comment 4 Stephen Gallagher 2017-11-06 18:18:01 UTC
There's an updated fonts module that makes the above changes. It'll be in the next compose, assuming this gets granted a Freeze Exception.

Comment 5 Geoffrey Marr 2017-11-06 19:48:10 UTC
Discussed during the 2017-11-06 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made as this bug cannot be fixed with just an update and thus warrants a freeze exception. This will ensure an available profile for the fonts module can actually be installed without errors.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-11-06/f27-blocker-review.2017-11-06-17.00.txt

Comment 6 Irina Gulina 2017-11-07 08:55:22 UTC
@Stephen Gallagher, sorry, I wasn't explicit in the bug summary. Those errors appeared on 

>> dnf module install fonts/everything

Comment 7 Irina Gulina 2017-11-09 09:48:06 UTC
Created attachment 1349846 [details]
module install fonts/everything logs

Comment 8 Irina Gulina 2017-11-09 09:48:40 UTC
The error changed, please see the attachment in the previous comment.

Comment 9 Stephen Gallagher 2017-11-13 13:01:45 UTC
(In reply to Irina Gulina from comment #8)
> The error changed, please see the attachment in the previous comment.

Irina, there was a compose bug that resulted in most of the fonts disappearing from the composed RPM repository. This has been fixed, so please retest with the latest nightly build.

Comment 10 Irina Gulina 2017-11-13 15:45:08 UTC
>> sudo docker run bikeshed bash -l -c "dnf --allowerasing install coreutils -y && dnf module install fonts/everything -y ; dnf module list"

successfully installs fonts/everything on Fedora-Modular-27-20171113.n.0: 

<...>
 urw-base35-z003-fonts.noarch 20170801-2.module_bedbd3b3                       
  xorg-x11-server-utils.x86_64 7.7-23.module_fa1f7807                           

Complete!
Last metadata expiration check: 0:12:51 ago on Mon 13 Nov 2017 03:29:41 PM UTC.
Fedora Modular Server 27 - x86_64
Name                Stream          Version          Profiles                   
389-ds              1.3 [d]         20171102233352   default                    
X11-base            f27 [d][e]      20171103131108   default                    
apache-commons      f27 [d]         20171018085030   default                    
autotools           f27 [d]         20171018090442   default                    
bind                9 [d]           20171018084824   client, default, ...       
cloud-init          f27 [d]         20171017101923   default                    
fonts               f27 [d][e]      20171109145641   default, everything [i]    
freeipa             4.6 [d]         20171104182858   default                    

<...>                   

Hint: [d]efault, [e]nabled, [i]nstalled, [l]ocked


Note You need to log in before you can comment on or make changes to this bug.