Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509969 - [UPDATES] UC Minor update fails: IOError: [Errno 13] Permission denied: '/var/log/ironic/ironic-dbsync.log'
Summary: [UPDATES] UC Minor update fails: IOError: [Errno 13] Permission denied: '/va...
Keywords:
Status: CLOSED DUPLICATE of bug 1507863
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-ironic
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 13:23 UTC by Yurii Prokulevych
Modified: 2017-11-06 13:56 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-06 13:56:21 UTC


Attachments (Terms of Use)

Description Yurii Prokulevych 2017-11-06 13:23:03 UTC
Description of problem:
-----------------------
Similar like in bz 1507863

UC's minor update fails
...
2017-11-06 08:09:04 - Notice: /Stage[main]/Keepalived::Service/Service[keepalived]: Triggered 'refresh' from 1 events
2017-11-06 08:09:05 - Notice: /Stage[main]/Mistral::Db::Sync/Exec[mistral-db-sync]/returns: executed successfully
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns: Option "rpc_backend" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns: Traceback (most recent call last):
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/bin/ironic-dbsync", line 10, in <module>
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     sys.exit(main())
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/cmd/dbsync.py", line 102, in main
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     service.prepare_service(sys.argv)
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/common/service.py", line 47, in prepare_service
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     log.setup(CONF, 'ironic')
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/oslo_log/log.py", line 269, in setup
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     _setup_logging_from_conf(conf, product_name, version)
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/oslo_log/log.py", line 366, in _setup_logging_from_conf
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     filelog = file_handler(logpath)
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/lib64/python2.7/logging/handlers.py", line 392, in __init__
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     logging.FileHandler.__init__(self, filename, mode, encoding, delay)
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/lib64/python2.7/logging/__init__.py", line 902, in __init__
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     StreamHandler.__init__(self, self._open())
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:   File "/usr/lib64/python2.7/logging/__init__.py", line 925, in _open
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns:     stream = open(self.baseFilename, self.mode)
2017-11-06 08:10:03 - Notice: /Stage[main]/Ironic::Db::Sync/Exec[ironic-dbsync]/returns: IOError: [Errno 13] Permission denied: '/var/log/ironic/ironic-dbsync.log'
2017-11-06 08:10:03 - Error: ironic-dbsync --config-file /etc/ironic/ironic.conf  returned 1 instead of one of [0]


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-ironic-conductor-6.2.4-2.el7ost.noarch
python-ironicclient-1.7.1-1.el7ost.noarch
openstack-ironic-common-6.2.4-2.el7ost.noarch
python-ironic-lib-2.1.3-1.el7ost.noarch
puppet-ironic-9.5.0-2.el7ost.noarch
openstack-ironic-api-6.2.4-2.el7ost.noarch
openstack-ironic-inspector-4.2.2-3.el7ost.noarch
python-ironic-inspector-client-1.10.0-1.el7ost.noarch


Steps to Reproduce:
-------------------
1. Deploy RHOS-10 env
2. Setup latest repos(z6) on UC
3. Follow update procedure

Actual results:
---------------
UC update fails


Expected results:
-----------------
UC update succeeds 

Additional info:
----------------
/var/log/ironic/ironic-dbsync.log is owned by root:root
Having patch 517356 doesn't eliminate issue.
Removing file before update helps.

Comment 1 Dmitry Tantsur 2017-11-06 13:26:58 UTC
Not sure why the fix in https://bugzilla.redhat.com/show_bug.cgi?id=1507863 does not help, needs investigation.

Comment 2 Dmitry Tantsur 2017-11-06 13:56:21 UTC
This is really a duplicate, the patch was just incorrect.

*** This bug has been marked as a duplicate of bug 1507863 ***


Note You need to log in before you can comment on or make changes to this bug.