Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509966 - Fedora-release can be removed
Summary: Fedora-release can be removed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 13:15 UTC by makopec
Modified: 2017-11-07 09:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-06 18:21:45 UTC


Attachments (Terms of Use)
DNF log (deleted)
2017-11-06 13:22 UTC, makopec
no flags Details

Description makopec 2017-11-06 13:15:33 UTC
Description of problem:
During update the dnf removed fedora-realease

Version-Release number of selected component (if applicable):
fedora-release-26-1.noarch

Steps to Reproduce:
dnf update --best --allowerasing

Actual results:
removed fedora-release

Expected results:
fedora-release should not be removed as it should be protected package

Additional info:
see log

Comment 1 makopec 2017-11-06 13:22:10 UTC
Created attachment 1348584 [details]
DNF log

Comment 2 Kevin Fenzi 2017-11-06 18:21:45 UTC
So, the problem here is that you in the past installed epel-release on a Fedora system. We added a Conflicts: fedora-release to prevent that, but you already had the package installed, so when you upgraded it, dnf decided the best way out of the problem was to install generic-release. 

We cannot add fedora-release to protected because people can and do use generic-release for remixes. 

You should remove epel-release and reinstall fedora-release. 

I don't think there's much we can do here... new installs shouldn't be able to install epel-release so the underlying probelm should now be avoided.

Comment 3 Zbigniew Jędrzejewski-Szmek 2017-11-06 20:22:24 UTC
(In reply to Kevin Fenzi from comment #2)
> We cannot add fedora-release to protected because people can and do use
> generic-release for remixes. 
Hmm, but when this happens, they just install generic-release directly, without installing and uninstalling fedora-release first, no?

Comment 4 Peter Robinson 2017-11-07 09:56:21 UTC
> We cannot add fedora-release to protected because people can and do use
> generic-release for remixes. 

Well the solution to that would be to protect "system-release" which is provided by both fedora-release and generic-release and not by epel-release.

I have some vague recollection that there was some issue with dnf dealing with this though so it would need to be tested and if it doesn't work convince the dnf team it's a bug that needs fixing.


Note You need to log in before you can comment on or make changes to this bug.