Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509962 - OVF update doesn't occur when create VM without disk and storage domain enter to maintenance
Summary: OVF update doesn't occur when create VM without disk and storage domain enter...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Eyal Shenitzky
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 13:01 UTC by Ori Ben Sasson
Modified: 2018-04-26 08:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:00:46 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
logs (deleted)
2017-11-06 13:01 UTC, Ori Ben Sasson
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83679 master MERGED core: Fix OVF update for vm without disks 2017-11-07 13:45:06 UTC

Description Ori Ben Sasson 2017-11-06 13:01:52 UTC
Created attachment 1348582 [details]
logs

Description of problem:
OVF update doesn't occur when storage domain enter to maintenance 

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20171105155215.git59d3324.el7.centos.noarch

How reproducible:
100

Steps to Reproduce:
1. Create VM without disk
1. detach and deactivate NFS storage domain
3. remove storage domain
4. remove VM
5  import the storage domain
6. attach storage domain to dc

Actual results:
it's impossible to import VM from storage domain

Expected results:
should work as expected

Comment 1 Ori Ben Sasson 2017-11-06 13:07:04 UTC
Fix to description:  OVF update doesn't occur when create VM without disk and storage domain enter to maintenance

Comment 2 Red Hat Bugzilla Rules Engine 2017-11-06 13:09:55 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Yaniv Kaul 2017-11-07 06:12:40 UTC
Why is it a high severity bug? What's the common use case of a diskless VM?

Comment 4 Raz Tamir 2017-11-15 09:50:19 UTC
Verified on ovirt engine-4.2.0-0.0.master.20171113223918.git25568c3.el7.centos

VM was registered successfully.

Comment 5 Ori Ben Sasson 2017-11-28 09:23:06 UTC

(In reply to Yaniv Kaul from comment #3)
> Why is it a high severity bug? What's the common use case of a diskless VM?

all our plan failed due to this bug.

Comment 6 Yaniv Kaul 2017-11-28 10:53:26 UTC
(In reply to Ori Ben Sasson from comment #5)
> 
> (In reply to Yaniv Kaul from comment #3)
> > Why is it a high severity bug? What's the common use case of a diskless VM?
> 
> all our plan failed due to this bug.

So fix your plan - you should hardly be testing with diskless VMs.

Comment 7 Sandro Bonazzola 2017-12-20 11:00:46 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.