Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509959 - The visibility and enablement expressions for buttons are not honoured in Self Service UI
Summary: The visibility and enablement expressions for buttons are not honoured in Sel...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Chris Hale
QA Contact: Dave Johnson
URL:
Whiteboard:
: 1534025 (view as bug list)
Depends On:
Blocks: 1513498
TreeView+ depends on / blocked
 
Reported: 2017-11-06 12:59 UTC by Milan Falešník
Modified: 2018-06-21 20:38 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1513498 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:38:06 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Milan Falešník 2017-11-06 12:59:59 UTC
Description of problem:
When there is a visibility expression on a button, it is never displayed in SSUI and no matter what does the enablement expression return if set, it is always enabled.

Version-Release number of selected component (if applicable):
5.9.0.5

How reproducible:
always

Steps to Reproduce:
1. Create a button, eg. for Service in this case. Set the visibility and enablement expression to eg. some tags.
2. Create a service
3. Go to the Self Service UI, select the service and look for the button and its status
4. Repeat 3 with setting and unsetting the appropriate tags and also removing either or both of the expressions

Actual results:
When the visibility expression is set, the button is always hidden no matter what is the outcome of it.
Enablement expression seems to have no effect on the buttons as once they are visible, they are clickable.

Expected results:
Buttons displayed exactly like in the Classic UI.

Additional info:

Comment 2 Chris Hale 2017-11-14 19:57:04 UTC
GH PR - https://github.com/ManageIQ/manageiq-ui-service/pull/1239

Comment 4 Yuri Rudman 2018-01-19 15:10:25 UTC
*** Bug 1534025 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.