Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509956 - [Regression] CPU Utilization shows nothing in Projects' Dashboard
Summary: [Regression] CPU Utilization shows nothing in Projects' Dashboard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Ari Zellner
QA Contact: Einat Pacifici
URL:
Whiteboard: container:ui
Depends On:
Blocks: 1461618 1521029
TreeView+ depends on / blocked
 
Reported: 2017-11-06 12:38 UTC by Pavel Zagalsky
Modified: 2018-06-21 20:46 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1521029 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:46:37 UTC
Category: Bug
Cloudforms Team: Container Management


Attachments (Terms of Use)
MonitoringUtilization (deleted)
2017-11-06 12:38 UTC, Pavel Zagalsky
no flags Details
ProjectsDashboard (deleted)
2017-11-06 12:39 UTC, Pavel Zagalsky
no flags Details
suggested solution for low not eounded numbers (deleted)
2017-11-16 15:04 UTC, Barak
no flags Details

Description Pavel Zagalsky 2017-11-06 12:38:41 UTC
Created attachment 1348580 [details]
MonitoringUtilization

Description of problem:
CPU Utilization shows nothing in Projects' Dashboard

Version-Release number of selected component (if applicable):
5.9.0.5

How reproducible:
Always

Steps to Reproduce:
1. Add Containers Provider
2. Add some pods to the provider
3. Wait a day or two
4. Go to Compute --> Containers --> Projects
5. Select the Default Project's Dashboard View

Actual results:
The CPU Utilization shows nothing even though if you go to this project's Capacity & Utilization menu from Monitoring you will see data

Expected results:
There should be the same data in Project's Dashboard as in Monitoring --> Capacity & Utilization

Additional info:
Attached screenshots

Comment 2 Pavel Zagalsky 2017-11-06 12:39:13 UTC
Created attachment 1348581 [details]
ProjectsDashboard

Comment 4 Ari Zellner 2017-11-16 09:36:29 UTC
The problem seems to be that utilization is so low on those projects that the dashboard rounds the values to zero. The graphs under the 'utlization' are scaled to those low values and im not sure we should do the same on the graphs in the dashboard. Seeking UI help on this one...

https://gitter.im/ManageIQ/manageiq/ui?at=5a0d5aae540c78242d0dcb0f

Comment 5 Barak 2017-11-16 15:04:28 UTC
Created attachment 1353554 [details]
suggested solution for low not eounded numbers

Comment 6 Barak 2017-11-16 15:05:23 UTC
After discussion with Serena ,
It was decided to pass non rounded numbers so in case the cpu consumption is very low (<1) it will still show in the graph.

See attachment 1353554 [details]


Note You need to log in before you can comment on or make changes to this bug.