Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509941 - EC2 provider add button disabled even after successful validation
Summary: EC2 provider add button disabled even after successful validation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: GA
: 5.10.0
Assignee: Jerry Keselman
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:provider:ec2
: 1512158 (view as bug list)
Depends On:
Blocks: 1513240
TreeView+ depends on / blocked
 
Reported: 2017-11-06 12:12 UTC by Matouš Mojžíš
Modified: 2018-06-21 21:14 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1513240 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:14:17 UTC
Category: ---
Cloudforms Team: AWS


Attachments (Terms of Use)
disabled add button ec2 provider (deleted)
2017-11-06 12:13 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2017-11-06 12:12:13 UTC
Description of problem:


Version-Release number of selected component (if applicable):
5.9.0.5

How reproducible:


Steps to Reproduce:
1.Try to add an ec2 provider
2.
3.

Actual results:
Can't add ec2 provide because add button is disabled even after validation.
It's probably disabled because there are no docker SSA container credentials, but these should not be required?
Expected results:


Additional info:

Comment 2 Matouš Mojžíš 2017-11-06 12:13:09 UTC
Created attachment 1348547 [details]
disabled add button ec2 provider

Comment 3 Jerry Keselman 2017-11-06 14:44:44 UTC
Not entirely true.  If you click through onto the Docker Credentials tab the "Add" button is enabled.  This is a known issue that was discussed (albeit briefly) during the Sprint demo...  Will look into a fix.

Comment 4 Jerry Keselman 2017-11-06 19:19:21 UTC
Changes implemented as suggested by Aparna Karve allow this issue to be resolved.  PR https://github.com/ManageIQ/manageiq-ui-classic/pull/2645 implements the fix.

Comment 5 Jerry Keselman 2017-11-07 21:21:29 UTC
The above PR has been merged.  We need a cloned BZ for Gaprindashvili and then this can go to POST.

Comment 6 Jerry Keselman 2017-11-13 13:35:08 UTC
*** Bug 1512158 has been marked as a duplicate of this bug. ***

Comment 8 Matouš Mojžíš 2018-06-21 16:17:52 UTC
Verified in 5.10.0.1. Ec2 provider add button is enabled after successfull validation.


Note You need to log in before you can comment on or make changes to this bug.