Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509917 - cannot change password with "+" at the start to the same without it
Summary: cannot change password with "+" at the start to the same without it
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine-extension-aaa-jdbc
Classification: oVirt
Component: General
Version: 1.1.5
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ---
: ---
Assignee: Martin Perina
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 10:44 UTC by Lucie Leistnerova
Modified: 2017-11-07 06:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-07 06:52:38 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Lucie Leistnerova 2017-11-06 10:44:30 UTC
Description of problem:
Script ovirt-aaa-jdbc-tool fails with 'new password already used' when I want to change password from string starting with "+" to the same string without it.

Version-Release number of selected component (if applicable):
ovirt-engine-extension-aaa-jdbc-1.1.6-1.el7ev.noarch

How reproducible: always


Steps to Reproduce:
1. change admin password to +123456
ovirt-aaa-jdbc-tool user password-reset admin
Password:
2. password changed, can log into admin portal, cannot log in with 123456
3. change admin password to 123456

Actual results: password was not changed, error 'new password already used'


Expected results: password changed

Comment 1 Martin Perina 2017-11-06 14:56:30 UTC
Following works for me:

1. Set password to 'admin'
    ovirt-aaa-jdbc-tool user password-reset admin --password-valid-to='2022-01-01 00:00:00Z' --password='pass:admin'

2. Login with password 'admin' and logout

3. Set password to '+123456'

    ovirt-aaa-jdbc-tool user password-reset admin --password-valid-to='2022-01-01 00:00:00Z' --password='pass:+123456'

4. Login with password '+123456' and logout

5. Set password to '123456'

    ovirt-aaa-jdbc-tool user password-reset admin --password-valid-to='2022-01-01 00:00:00Z' --password='pass:123456'

6. Login with password '123456'


Are you sure that you have not set password '123456' before setting to '+123456'? If so that, it's correct to fail, because by defalt aaa-jdbc remembers last 3 password and the same password cannot be set again:

    ovirt-aaa-jdbc-tool settings show --name=PASSWORD_HISTORY_LIMIT

Comment 2 Lucie Leistnerova 2017-11-07 06:52:38 UTC
Yes, it works as you say. I'm sorry, my mistake.


Note You need to log in before you can comment on or make changes to this bug.