Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509901 - On expression specification for a button, after pressing the button, the tab is switched
Summary: On expression specification for a button, after pressing the button, the tab ...
Keywords:
Status: CLOSED DUPLICATE of bug 1501051
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.9.0
Assignee: lgalis
QA Contact: Milan Falešník
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 10:05 UTC by Milan Falešník
Modified: 2017-12-11 14:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-08 15:30:41 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Milan Falešník 2017-11-06 10:05:47 UTC
Description of problem:
When defining visibility and enablement expressions, upon clicking the button to open the expression editor the tab is switched, which is inconvenient. This happens for both Define and Edit expression buttons.

Version-Release number of selected component (if applicable):
5.9.0.5

How reproducible:
always

Steps to Reproduce:
1. Open the dialog to add a new button.
2. Switch to the second tab.
3. Click any of the "Define expression"

Actual results:
You are bumped back to the first tab.
If you then edit the other expression, the original expression's button changes to "Edit expression", which does the same.

Expected results:
You stay on the second tab.

Additional info:
It appears to not impair the functionality, but it looks awful, therefore setting medium severity.

Comment 2 Chris Pelland 2017-12-08 15:30:41 UTC

*** This bug has been marked as a duplicate of bug 1501051 ***


Note You need to log in before you can comment on or make changes to this bug.