Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509896 - Tasks page should be closed when using vertical navigation
Summary: Tasks page should be closed when using vertical navigation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Alexander Wels
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 09:52 UTC by Oved Ourfali
Modified: 2017-12-20 11:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:33:41 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83661 master MERGED webadmin: hide overlay when using menu 2017-11-06 19:45:03 UTC
oVirt gerrit 84214 master MERGED webadmin: overlay visibility 2017-11-16 16:26:09 UTC

Description Oved Ourfali 2017-11-06 09:52:36 UTC
Description of problem:
Currently, when you open the tasks, if you go to the vertical navigation and go somewhere, you still have the tasks open instead of browsing to the requested tab. Browsing should automatically close the tasks screen.

Comment 1 Lucie Leistnerova 2017-11-14 12:53:04 UTC
It doesn't close Tasks when trying to open the same menu item as the one from where the Tasks were opened before.

Steps to reproduce:
1. go to Storage -> Domains
2. click on Tasks in top right menu, tasks are displayed
3. go to Storage -> Domains again from left menu, Tasks are still there


Other problem is that Tasks are not opened after closed from left menu item.

Steps to reproduce:
1. go to Storage -> Domains
2. click on Tasks in top right menu, tasks are displayed
3. go to Compute -> Virtual Machines
4. Tasks are closed, VMs displayed
5. click on Tasks in top right menu - no tasks displayed (no error in logs, browser console)
6. click again on Tasks - tasks are displayed

tested in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20171113223918.git25568c3.el7.centos.noarch

Comment 2 Alexander Wels 2017-11-15 19:59:09 UTC
So there is literally nothing I can do about the first problem. You are going to a spot you are at already, so nothing happens. The tags/bookmarks/tasks are simply overlays on top of the location you are at. In this example case domains. Only if you switch locations will something happen that will allow me to close the overlay.

The second issue will be fixed with a patch.

Comment 3 Lucie Leistnerova 2017-11-20 09:01:51 UTC
Alright, tasks can be closed other way, so it's a minor issue.
It works now as expected.

verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20171119135709.git6d448d3.el7.centos.noarch

Comment 4 Sandro Bonazzola 2017-12-20 11:33:41 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.