Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509883 - Application installer are not able to install flatpak from web
Summary: Application installer are not able to install flatpak from web
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-software
Version: 7.5
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Kalev Lember
QA Contact: Desktop QE
Jana Heves
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 09:24 UTC by Martin Krajnak
Modified: 2018-04-10 13:56 UTC (History)
7 users (show)

Fixed In Version: gnome-software-3.22.7-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 13:55:50 UTC


Attachments (Terms of Use)
app log (deleted)
2017-11-06 09:26 UTC, Martin Krajnak
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0803 None None None 2018-04-10 13:56:17 UTC

Description Martin Krajnak 2017-11-06 09:24:08 UTC
Description of problem:
Downloading flapak, opening in nautilus, clicking on install button, nothing happend.

Reason:
08:37:43:0813 Gs  user/flatpak/*/runtime/org.gnome.Platform/3.24 runtime cannot have runtime!

I think there should be some feedback provided or alert, so user can take action e.g. install runtime

Furthermore, I've also tried to add flathub repo via:
sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

so the flathub apps can can be browsed, still cannot be installed:
09:03:16:0131 Gs  failed to call gs_plugin_app_install on flatpak: Remote "com.transmissionbt.Transmission-origin" not found
09:03:16:0131 Gs  not saving error for user/flatpak/com.transmissionbt.Transmission-origin/desktop/com.transmissionbt.Transmission.desktop/stable: Remote "com.transmissionbt.Transmission-origin" not found


Version-Release number of selected component (if applicable):
flatpak-0.8.8-1.el7.x86_64
flatpak-0.8.8-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Go to flathub
2.Download flatpak/Choose open via application installer
3.Click Download

1.Go to flathub
2.Install flathub repo via cmd
3.Open Application Installer
4. Search flatpack and try to install

Actual results:
User can click the Install button many times, but there is no action and application itself provides no feedback.

Expected results:
User should be able to install those flatpaks or should at least be provided with some error/feedback that the flatpak won't install.

Additional info:
Failing flatpaks are instalable via command line tool without errors.

Comment 2 Martin Krajnak 2017-11-06 09:26:56 UTC
Created attachment 1348486 [details]
app log

Comment 3 Martin Krajnak 2017-11-06 13:48:11 UTC
I played around a bit and adding the flathub repo is look like it is a workaround for installing flatpaks from web but gnome-software needs to be killed few times. Installing right from firefox or nautilus is not working anyway.

Comment 5 Kalev Lember 2018-02-06 12:50:00 UTC
We need to backport a tiny non-invasive fix from upstream to get this working.

lmiksik, could you provide pm_ack+ and exception+, please?

Comment 7 Tomas Pelka 2018-02-07 13:43:31 UTC
(In reply to Kalev Lember from comment #5)
> We need to backport a tiny non-invasive fix from upstream to get this
> working.
> 
> lmiksik, could you provide pm_ack+ and exception+, please?

Managed to get blocker approved, please Kalev when you get a change either build or let me know who could do it.

Thanks
-Tom

Comment 8 Kalev Lember 2018-02-07 14:01:01 UTC
Thanks Tom. Pushed the fix and building now.

Comment 11 Martin Krajnak 2018-02-07 15:35:09 UTC
Fixed in gnome-software-3.22.7-5.el7.x86_64

Comment 16 errata-xmlrpc 2018-04-10 13:55:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0803


Note You need to log in before you can comment on or make changes to this bug.