Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509862 - xpdf cannot find display fonts
Summary: xpdf cannot find display fonts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xpdf
Version: 27
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 08:54 UTC by Yaakov Selkowitz
Modified: 2018-10-11 14:44 UTC (History)
5 users (show)

Fixed In Version: xpdf-4.00-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-15 17:47:07 UTC


Attachments (Terms of Use)
Possible patch (deleted)
2017-11-06 09:39 UTC, Yaakov Selkowitz
no flags Details | Diff

Description Yaakov Selkowitz 2017-11-06 08:54:52 UTC
xpdf-4.00-2.fc27 cannot find the URW Base 35 fonts in their new location, leading to the following error messages upon startup:

Config Error: No display font for 'Courier'
Config Error: No display font for 'Courier-Bold'
Config Error: No display font for 'Courier-BoldOblique'
Config Error: No display font for 'Courier-Oblique'
Config Error: No display font for 'Helvetica'
Config Error: No display font for 'Helvetica-Bold'
Config Error: No display font for 'Helvetica-BoldOblique'
Config Error: No display font for 'Helvetica-Oblique'
Config Error: No display font for 'Symbol'
Config Error: No display font for 'Times-Bold'
Config Error: No display font for 'Times-BoldItalic'
Config Error: No display font for 'Times-Italic'
Config Error: No display font for 'Times-Roman'
Config Error: No display font for 'ZapfDingbats'

The cause appears to be hard-coded directories and file names for these fonts in xpdf/GlobalParams.cc, which do not conform to the new urw-base35-fonts layout.

Comment 1 Yaakov Selkowitz 2017-11-06 09:39:46 UTC
Created attachment 1348491 [details]
Possible patch

This silences all warnings and appears to display a PDF which uses some of these fonts correctly.  I haven't tested it extensively yet, though, and it's not backwards compatible with the old filenames.

Comment 2 Fedora Update System 2017-11-07 16:26:00 UTC
xpdf-4.00-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d6246f5fe0

Comment 3 Fedora Update System 2017-11-07 19:15:54 UTC
xpdf-4.00-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d6246f5fe0

Comment 4 Fedora Update System 2017-11-15 17:47:07 UTC
xpdf-4.00-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.