Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509849 - mutter SEGV in Wayland by no EXT_stereo_tree
Summary: mutter SEGV in Wayland by no EXT_stereo_tree
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1510014
Blocks: 1481401
TreeView+ depends on / blocked
 
Reported: 2017-11-06 08:12 UTC by fujiwara
Modified: 2018-05-17 14:39 UTC (History)
7 users (show)

Fixed In Version: mutter-3.26.2-2.el7.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 13:06:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch of compositor.c (deleted)
2017-11-06 08:13 UTC, fujiwara
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:07:01 UTC

Description fujiwara 2017-11-06 08:12:27 UTC
GNOME Wayland causes a SEGV:

#0  0x00007fbfbcaf2501 in __strstr_sse2 () at /lib64/libc.so.6
#1  0x00007fbfc32ddd86 in screen_has_stereo_tree_ext (screen=0xa6d6d0)
    at compositor/compositor.c:520
#2  0x00007fbfc32ddf35 in meta_compositor_manage (compositor=0x2472a90)
    at compositor/compositor.c:586
#3  0x00007fbfc32fb694 in enable_compositor (display=0x20e7400)
    at core/display.c:476
#4  0x00007fbfc32fd989 in meta_display_open () at core/display.c:966
#5  0x00007fbfc330ef0c in meta_run () at core/main.c:649
#6  0x0000000000402c4a in main (argc=1, argv=0x7fff8dd61818) at main.c:463

It's caused by the internal patch of 0008-Add-support-for-quad-buffer-stereo.patch in RHEL 7.5

I think my box does not work with the stereo extension.

Comment 2 fujiwara 2017-11-06 08:13:30 UTC
Created attachment 1348453 [details]
Patch of compositor.c

After applied this patch, mutter works fine.

Comment 17 errata-xmlrpc 2018-04-10 13:06:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.