Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509831 - Man page for yum.conf recommends multiple baseurl entries on separate line
Summary: Man page for yum.conf recommends multiple baseurl entries on separate line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 7.5
Assignee: Michal Domonkos
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks: 1549618
TreeView+ depends on / blocked
 
Reported: 2017-11-06 07:35 UTC by Jayaraj
Modified: 2018-10-30 11:41 UTC (History)
2 users (show)

Fixed In Version: yum-3.4.3-159.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:40:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3279 None None None 2018-10-30 11:41:17 UTC

Description Jayaraj 2017-11-06 07:35:17 UTC
Description of problem:

The man page of yum.conf needs fixing as it says, multiple baseurl entries on separate line.

Extract from man page:

              baseurl Must be a URL to the directory where the yum repository's `repodata' directory lives. Can be an
              http://, ftp:// or file:// URL. You can specify multiple URLs in one baseurl statement. The best way to
              do this is like this:
              [repositoryid]
              name=Some name for this repository
              baseurl=url://server1/path/to/repository/
                      url://server2/path/to/repository/
                      url://server3/path/to/repository/


Version-Release number of selected component (if applicable):
RHEL 7.4


How reproducible:
100%

Steps to Reproduce:
1. Configure two or three active repositories 
2. Specify that two or three multiple URL's (as specified in yum.conf man page) in /etc/yum.repos.d/test.repo
3. Do yum clean all & yum repolist

Actual results:
yum will recognise the first come active URL's and ignore the rest.


Expected results:
Man pages of yum.conf needs to be corrected

Additional info:

==Test results==

[root@test ~]# cat /etc/yum.repos.d/test.repo
[ALL-REPO]
name=Global
baseurl=file:///var/tmp/rhel7/Server
        file:///var/tmp/rhel5/Server
enabled=1
gpgcheck=0



[root@test ~]# yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
ALL-REPO                                                                                                                                                                                    | 3.7 kB  00:00:00    
(1/2): ALL-REPO/group_gz                                                                                                                                                                    | 136 kB  00:00:00    
ALL-REPO/primary_db            FAILED                                         
file:///var/tmp/rhel5/Server/repodata/9c73edc617492593e4086812141357ed8d8cba4cdb352b7de382bd6acad2a17a-primary.sqlite.bz2: [Errno 14] curl#37 - "Couldn't open file /var/tmp/rhel5/Server/repodata/9c73edc617492593e4086812141357ed8d8cba4cdb352b7de382bd6acad2a17a-primary.sqlite.bz2"
Trying other mirror.
(2/2): ALL-REPO/primary_db                                                                                                                                                                  | 4.0 MB  00:00:00    
repo id                                                                                                repo name                                                                                             status
ALL-REPO                                                                                               Global                                                                                                4,986
repolist: 4,986

Comment 10 errata-xmlrpc 2018-10-30 11:40:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3279


Note You need to log in before you can comment on or make changes to this bug.