Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509817 - mate terminal tab title setting not possible
Summary: mate terminal tab title setting not possible
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-terminal
Version: 27
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 07:14 UTC by Frantisek Hanzlik
Modified: 2017-11-06 09:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-06 09:48:28 UTC


Attachments (Terms of Use)

Description Frantisek Hanzlik 2017-11-06 07:14:49 UTC
Description of problem:
Just installed Fedora 27/i386 with MATE desktop.
On running MATE Terminal with several tabs, I want to name them. When right click on tab, I can select "Set Title..." menu item, then "Set Title" window appear, where is possible fill "Title" field. But after confirm this setting with "OK" button, tab title stay unchanged - although entered new tab title is remembered (as I can see through a new attempt to set a title), the terminal still displays the original title of the tab.

Version-Release number of selected component (if applicable):
mate-terminal-1.19.0-1.fc27.i686

How reproducible:
Always, see the procedure above.

Expected results:
The tab should be renamed.

Additional info:
This naming was possible on previous MATE Terminal versions.

Comment 1 Wolfgang Ulbrich 2017-11-06 07:44:36 UTC
Go to profile preferences, choose the tab 'Title and commands', there is a drop-down menu, choose here 'replace origin title'.
That's it.

Comment 2 Frantisek Hanzlik 2017-11-06 09:26:10 UTC
Yeah, Wolfgang, thanks for your info, it works - older versions perhaps behave differently.

But still I'm not sure when it isn't bug - setting in 'Preferences' -> 'Title and commands' -> 'When terminal commands set their own titles' should be for terminal commands, but IMO the program should at least warn the user, or allow change title manually.

Comment 3 Wolfgang Ulbrich 2017-11-06 09:48:28 UTC
(In reply to Frantisek Hanzlik from comment #2)
> Yeah, Wolfgang, thanks for your info, it works - older versions perhaps
> behave differently.

We use this default since f23 for fedora with a gsettings override file.

> 
> But still I'm not sure when it isn't bug - setting in 'Preferences' ->
> 'Title and commands' -> 'When terminal commands set their own titles' should
> be for terminal commands, but IMO the program should at least warn the user,
> or allow change title manually.
Can you file out a report at upstream about a missing warning or that the option should be grey out in context menu, please?
https://github.com/mate-desktop/mate-terminal/issues
Thanks


Note You need to log in before you can comment on or make changes to this bug.