Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509803 - Add a new role definition for hosting SR-IOV
Summary: Add a new role definition for hosting SR-IOV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Saravanan KR
QA Contact: Maxim Babushkin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 06:38 UTC by Saravanan KR
Modified: 2018-06-27 13:39 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:39:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:48 UTC
OpenStack gerrit 501999 None master: MERGED tripleo-heat-templates: Added a new role definition for SR-IOV Compute role (If48bd6a69209da556cc75ece035b341eb59f41a9) 2018-03-29 16:07:42 UTC

Description Saravanan KR 2017-11-06 06:38:46 UTC
Description of problem:
Having SR-IOV service in the general Compute role is making the users to always modify the roles data file to create custom roles for compute(regular) and computesrivo. We have already faced this with multiple customer PoCs. In order to avoid this manual changes, it is required to separate SR-IOV services to a separate role.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Yariv 2018-06-14 09:56:48 UTC
Run the following 
openstack overcloud roles generate -o ./myroles.yaml ComputeSriov

file created also for ComputeSriovRT

Comment 7 errata-xmlrpc 2018-06-27 13:39:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.