Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509667 - provider-host in ovirt-provider-ovn.conf should be FQDN
Summary: provider-host in ovirt-provider-ovn.conf should be FQDN
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-provider-ovn
Classification: oVirt
Component: provider
Version: 1.0.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Marcin Mirecki
QA Contact: Mor
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-05 14:25 UTC by Mor
Modified: 2017-12-20 11:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:02:14 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
logs (deleted)
2017-11-05 16:02 UTC, Mor
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84442 master MERGED packaging: provider-host in ovirt-provider-ovn.conf should be FQDN 2017-11-24 13:06:29 UTC

Description Mor 2017-11-05 14:25:20 UTC
Description of problem:
provider-host value in ovirt-provider-ovn.conf is currently set up as 'localhost' by engine, where it should be FQDN to allow CFME to connect to it remotely.

Version-Release number of selected component (if applicable):
Version 4.2.0-0.0.master.20171103160151.gitcf446d9.el7.centos
ovirt-provider-ovn-1.2-0.20171102153014.git7bfd256.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Use engine-setup to setup OVN component.
2. cat /etc/ovirt-provider-conf.conf | grep provider-host.
3. Try to attach RHV through CFME interface.

Actual results:
CFME fails to connect to RHV, since 'localhost' is being used.

Expected results:
CFME should be able to connect remotely using a given FQDN name.

Additional info:

Comment 1 Mor 2017-11-05 16:02:36 UTC
Created attachment 1348167 [details]
logs

Comment 2 Dan Kenigsberg 2017-11-20 10:39:28 UTC
I would not like to ship 4.2.0 without it.

Comment 3 Mor 2017-12-07 15:52:21 UTC
Default setting for 'provider-host' is 'localhost':
# cat /etc/ovirt-provider-ovn/ovirt-provider-ovn.conf | grep provider-host
provider-host=localhost

Tested on:
ovirt-provider-ovn-1.2.1-1.el7ev.noarch
RHV 4.2.0-0.6.el7.noarch

Comment 4 Marcin Mirecki 2017-12-08 10:09:59 UTC
The setting is not done in the default file (this is not touched by the engine-setup).
Please check:
/etc/ovirt-provider-ovn/conf.d/10_engine_setup.conf

Comment 5 Marcin Mirecki 2017-12-08 10:10:22 UTC
The setting is not done in the default file (this is not touched by the engine-setup).
Please check:
/etc/ovirt-provider-ovn/conf.d/10_engine_setup.conf

Comment 6 Mor 2017-12-10 08:19:01 UTC
Found it, thanks.

# cat /etc/ovirt-provider-ovn/conf.d/10-setup-ovirt-provider-ovn.conf:

# This file is automatically generated by engine-setup. Please do not edit [PROVIDER]
provider-host=<FQDN>

Verified on:
RHV 4.2.0-0.6.el7
ovirt-provider-ovn 1.2.1-1.el7ev.noarch

Comment 7 Sandro Bonazzola 2017-12-20 11:02:14 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.