Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509664 - Token creation results in HTTP code 201 where it should be 200 (for CFME)
Summary: Token creation results in HTTP code 201 where it should be 200 (for CFME)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-provider-ovn
Classification: oVirt
Component: provider
Version: 1.0.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Dominik Holler
QA Contact: Mor
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-05 14:17 UTC by Mor
Modified: 2017-12-20 10:52 UTC (History)
4 users (show)

Fixed In Version: ovirt-provider-ovn-1.2-0.20171110095842.git22bbb0d.el7.centos.noarch.rpm
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-20 10:52:36 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
logs (deleted)
2017-11-05 16:03 UTC, Mor
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83620 master MERGED POST /v2.0/tokens returns 200 on success 2017-11-06 09:20:33 UTC

Description Mor 2017-11-05 14:17:49 UTC
Description of problem:
When creating a token the provider returns 201 ('Created') where it should return 200 ('OK') in order to support CFME connections.

Version-Release number of selected component (if applicable):
Version 4.2.0-0.0.master.20171103160151.gitcf446d9.el7.centos
ovirt-provider-ovn-1.2-0.20171102153014.git7bfd256.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Send a valid token request to the provider.
2. Get a response.

Actual results:
Provider returns HTTP code 201.

Expected results:
Provider should return HTTP code 200.

Additional info:

Comment 1 Dan Kenigsberg 2017-11-05 14:26:28 UTC
Isn't this a bug in CFME?

Comment 2 Mor 2017-11-05 16:03:42 UTC
Created attachment 1348170 [details]
logs

Comment 3 Dominik Holler 2017-11-06 08:18:29 UTC
According to https://developer.openstack.org/api-ref/identity/v2/index.html#authenticate , OpenStack Identity API v2.0 specifies HTTP 200 as return code for successful token creation, so CFME seems to be right and the provider has to be changed.

Comment 4 Mor 2017-11-14 06:47:34 UTC
Verified on:
ovirt-provider-ovn-1.2-0.20171110095842.git22bbb0d.el7.centos.noarch

Logging:
2017-11-14 08:44:44,792   Starting new HTTPS connection (1): network-ge-2.scl.lab.tlv.redhat.com
2017-11-14 08:44:49,844   "POST /ovirt-engine/sso/oauth/token-info HTTP/1.1" 200 324
2017-11-14 08:44:49,850   Response code: 200

Comment 5 Sandro Bonazzola 2017-12-20 10:52:36 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.