Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509659 - Modular Server is missing PackageKit
Summary: Modular Server is missing PackageKit
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-modular-release
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F27ServerBetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-11-05 13:47 UTC by Stephen Gallagher
Modified: 2018-03-29 12:34 UTC (History)
2 users (show)

Fixed In Version: Fedora-Modular-27-20171105.n.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1509662 (view as bug list)
Environment:
Last Closed: 2018-03-29 12:34:15 UTC


Attachments (Terms of Use)

Description Stephen Gallagher 2017-11-05 13:47:07 UTC
Description of problem:
The Modular Server is missing the PackageKit package, which is required for full operation of Cockpit (in particular, Cockpit support of joining domains).

Version-Release number of selected component (if applicable):
Fedora-Modular-27-20171105.n.0

How reproducible:
Every time

Steps to Reproduce:
1. Install a Fedora Server using Fedora-Modular-27-20171105.n.0 media
2. Log into Cockpit
3. Attempt to join the machine to a domain

Actual results:

```
* Couldn't find file: /usr/sbin/ipa-client-install
 * Required files: /usr/sbin/ipa-client-install, /usr/sbin/oddjobd, /usr/libexec/oddjob/mkhomedir, /usr/sbin/sssd
 * Resolving required packages
 ! PackageKit not available: The name org.freedesktop.PackageKit was not provided by any .service files
 ! Necessary packages are not installed: freeipa-client oddjob oddjob-mkhomedir sssd
```


Expected results:

Machine should be joined to the domain.

Additional info:
We will need to add this functionality to the platform to support Cockpit.

Comment 1 Fedora Blocker Bugs Application 2017-11-05 13:48:23 UTC
Proposed as a Blocker for 27-server-beta by Fedora user sgallagh using the blocker tracking app because:

 "It must be possible to log in to the default Cockpit instance and use it to [...] Enrol the system to a FreeIPA or Active Directory domain" from the Beta Release Criteria.

Comment 2 Stephen Gallagher 2017-11-06 01:07:31 UTC
This has been fixed as of Fedora-Modular-27-20171105.n.3

Comment 3 Geoffrey Marr 2017-11-06 19:41:03 UTC
Discussed during the 2017-11-06 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"It must be possible to log in to the default Cockpit instance and use it to [...] enroll the system to a FreeIPA or Active Directory domain"

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-11-06/f27-blocker-review.2017-11-06-17.00.txt


Note You need to log in before you can comment on or make changes to this bug.