Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509598 - can't install extensions from gnome.org; connector missing?
Summary: can't install extensions from gnome.org; connector missing?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-05 02:02 UTC by David Bolding
Modified: 2017-11-05 15:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-05 15:31:06 UTC


Attachments (Terms of Use)

Description David Bolding 2017-11-05 02:02:23 UTC
Description of problem:
The GNOME Shell Extension firefox plug-in doesn't work, it reports that the native host connector can't be found.  After maybe half an hour of searching, there doesn't seem to be an easy way to install the connector (if it's in the standard repo, it's not obviously named).

This makes it impossible to install extensions, as far as I know, which is a pretty big problem now that I have a pressing need to install an extension (TopIcon).

Version-Release number of selected component (if applicable):
Fedora 27 beta

How reproducible:
every time

Steps to Reproduce:
1. go to https://addons.mozilla.org/en-US/firefox/addon/gnome-shell-integration/ and install the firefox extension
2. go to https://extensions.gnome.org/

Actual results:
the local connector can't be found

Expected results:
the firefox extension contacts the connector, making gnome extensions installable

Additional info:
I notice that several gnome-shell-extensions are available as packages, so I assume that the decision to disable the mechanism to install extensions from extensions.gnome.org is deliberate.  I'm curious as to why?  It means that the normal process for installing extensions doesn't work, and I assume it makes more packaging work for you.  I can't help but also notice that f.ex. pip is not disabled in python, even though many python packages are also provided in the system repo.

This question might become more urgent, since they UX geniuses at Gnome decided to remove the system tray, and their recommended solution if that bothers you is apparently "install the TopIcon extension".

Comment 1 Mohamed El Morabity 2017-11-05 15:31:06 UTC
This bug is not related to the GNOME Shell extensions subpackages provided by Fedora.
Anyway to fix your problem, you'll need the Firefox extension AND the *chrome-gnome-shell* package to be installed (this package is required by Firefox, dispite its name).


Note You need to log in before you can comment on or make changes to this bug.