Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509544 - network-wait-online.target failure
Summary: network-wait-online.target failure
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-04 13:52 UTC by Sam Varshavchik
Modified: 2018-05-29 11:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 11:42:37 UTC


Attachments (Terms of Use)

Description Sam Varshavchik 2017-11-04 13:52:51 UTC
# egrep 'create socket|Wait Online' /var/log/messages
Nov  4 09:16:52 shorty systemd[1]: Started Network Manager Wait Online.
Nov  4 09:16:52 shorty sockd[1245]: Cannot create socket on 192.168.0.1, port 1080: Cannot assign requested address

syslog logged successful completion of this target. Immediately afterwards there were failures to start services because 192.168.0.1 didn't come up yet.

# grep 192.168.0.1 /var/log/privoxy/logfile
2017-11-04 09:16:52.710 7f8d7a298700 Fatal error: can't bind to 192.168.0.1:8000: Cannot assign requested address

That was another one. Had to manually restart everything.

There's nothing special about this IP address. It is statically assigned, so DHCP is completely out of the loop here:

# cat ifcfg-eno1
TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=lan0
UUID=d1a1ee90-f006-43bb-9cbf-175ad32f6565
ONBOOT=yes
HWADDR=0C:C4:7A:32:C1:82
IPADDR=192.168.0.1
PREFIX=24
DOMAIN=email-scan.com
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
DNS1=192.168.0.1

Comment 1 Gordon Messmer 2017-11-17 00:05:15 UTC
I tried to reproduce this problem, but wasn't able to.

I did some additional testing by creating a shell script, /usr/local/bin/ip-log, containing: 

    #!/bin/sh
    /usr/sbin/ip addr show | logger

I ran "systemctl edit NetworkManager-wait-online" and added two lines to the override file:

    [Service]
    ExecStart=/usr/local/bin/ip-log

... and rebooted.  Boot logs record that most services start 14-16 seconds past the minute and that NetworkManager starts setting up.  It takes six seconds to connect to WiFi and get an address from DHCP.  At 22 seconds past the minute, the output of "ip addr show" is logged, and then privoxy starts.

The state of the network might reveal more about why the "network-wait-online" target isn't waiting for 192.168.0.1 to be available.

Comment 2 Gordon Messmer 2017-12-20 04:57:27 UTC
This problem appears to be caused by an extensive delay in establishing carrier link for the Ethernet interface.  A recent NetworkManager commit should provide a way to address this and several other bugzilla entries, once NetworkManager 1.10.2 or newer is available in Fedora.

https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=2becc0a0ac82834ea96898c17ec79cd038e6db54

Comment 3 Fedora End Of Life 2018-05-03 08:16:41 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2018-05-29 11:42:37 UTC
Fedora 26 changed to end-of-life (EOL) status on 2018-05-29. Fedora 26
is no longer maintained, which means that it will not receive any
further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.