Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509525 - [RFE] Users would like to see logs and metrics from the Router
Summary: [RFE] Users would like to see logs and metrics from the Router
Keywords:
Status: CLOSED DUPLICATE of bug 1438482
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Eric Paris
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-04 12:30 UTC by Bruno Andrade
Modified: 2017-11-22 17:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 17:38:59 UTC


Attachments (Terms of Use)

Description Bruno Andrade 2017-11-04 12:30:17 UTC
Description of problem:

Would be great if metrics and logs from the HAProxy router could be directed to the OpenShift Log Stack.  Of course it ought to respect the RBAC for tenancy.

1. Why exactly do you need this feature? (List the business requirements here)
Clients want to:
     1. See that router configurations like disabling stickiness through annotations actually take effect
     2. See response codes and timing from router for troubleshooting and performance analysis

2. How would you like to achieve this? (List the functional requirements here)
I would like the router logs that can be enabled and sent to a syslog server,  to be collected and sent to the OpenShift logging service.  The logs should be available in the operations index for admins and additionally, the same SNI rules the router uses could be used to split the logs into appropriate indexes for the clients so they can see the logs relevant to their services.

3. Do you have any specific timeline dependencies?
The sooner, the better.  Clients are asking for the capability and we don't have an alternative method of providing the the data they are asking for.

4. Would you be able to assist in testing this functionality if implemented?
yes

Comment 2 Bruno Andrade 2017-11-22 17:38:59 UTC

*** This bug has been marked as a duplicate of bug 1438482 ***


Note You need to log in before you can comment on or make changes to this bug.