Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509482 - Numerous swiftclient 401 Unauthorized errors in gnocchi logs
Summary: Numerous swiftclient 401 Unauthorized errors in gnocchi logs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-swiftclient
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: z9
: 10.0 (Newton)
Assignee: Julien Danjou
QA Contact: Sasha Smolyak
URL:
Whiteboard:
: 1509481 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-03 21:50 UTC by Mircea Vutcovici
Modified: 2018-11-20 11:43 UTC (History)
13 users (show)

Fixed In Version: python-swiftclient-3.1.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 11:43:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github gnocchixyz gnocchi pull 494 None None None 2017-11-17 09:29:32 UTC

Comment 6 Mircea Vutcovici 2017-11-07 22:50:58 UTC
*** Bug 1509481 has been marked as a duplicate of this bug. ***

Comment 10 Julien Danjou 2017-11-20 09:01:39 UTC
@Prad: this is fixed in Gnocchi 3.0.16, can we make sure to rebase and push this into a next Z stream?

Comment 11 Julien Danjou 2017-11-25 10:58:07 UTC
Note that the fix in Gnocchi will not cover all the wrong exceptions. It needs fixes that have been done in swiftclient >= 3.1.0.

Comment 13 Christian Schwede (cschwede) 2018-03-07 15:05:35 UTC
Current python-swiftclient version in 10z is python-swiftclient-3.1.0-2.el7ost (https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=634295), should be fine from a swiftclient perspective.

Comment 15 Jon Schlueter 2018-10-11 16:20:38 UTC
According to our records, this should be resolved by python-swiftclient-3.1.0-2.el7ost.  This build is available now.

Comment 16 Sasha Smolyak 2018-11-19 12:46:53 UTC
No errors in log or in swiftclient. Fixed


Note You need to log in before you can comment on or make changes to this bug.