Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509478 - libffado FTBFS on f27 and rawhide
Summary: libffado FTBFS on f27 and rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libffado
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brendan Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-03 21:36 UTC by Merlin Mathesius
Modified: 2017-11-14 09:23 UTC (History)
3 users (show)

Fixed In Version: libffado-2.3.0-7.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 00:55:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1507581 None None None Never

Internal Links: 1507581

Description Merlin Mathesius 2017-11-03 21:36:39 UTC
Description of problem:
libffado no longer builds on Fedora F27 or Rawhide. The last successful build was in August 11, 2017 for F27.

Version-Release number of selected component (if applicable):
libffado-2.3.0-6.fc28
libffado-2.3.0-6.fc27

How reproducible:
always

Steps to Reproduce:
1. fedpkg clone libffado
2. cd libffado
3. fedpkg scratch-build
4. fedpkg --release f27 scratch-build

Actual results:
Failed Rawhide build: https://koji.fedoraproject.org/koji/taskinfo?taskID=22897975
Failed F27 build: https://koji.fedoraproject.org/koji/taskinfo?taskID=22898241

Expected results:
Successful package build

Additional info:
Package still builds successfully for F26: https://koji.fedoraproject.org/koji/taskinfo?taskID=22898895

The issue appears to be that F27 and Rawhide only have scons-3.x available in the buildroot, but the SConstruct file within the libffado package source is compatible only with scons-2.x.

Comment 1 Orcan Ogetbil 2017-11-05 20:07:44 UTC
I spent about an hour for this. Apart from converting Python2 prints to Python3 prints, there are a lot of other incompatibilities that need to be addressed, e.g. some functions expect bytes whereas the current buildsystem sends in strings. 

It is not trivial work to update the build scripts to Scons3. Will Fedora ship a scons2 legacy version? This looks like the easiest solution.

Comment 2 Merlin Mathesius 2017-11-06 14:51:24 UTC
Unfortunately, I know nothing of the plans for scons. However, I did run across BZ#1507581 that is related to mypaint also FTBFS with scons3.

Comment 3 Orcan Ogetbil 2017-11-07 04:56:58 UTC
I managed to make a patch with bunch of workarounds to build libffado with scons3 (patch sent upstream). It skips a few checks during the initial setup, but it completes the build now which is certainly better than FTBFS. 
When upstream switches to scons3, we will have a better solution.
Submitting an update shortly.

Comment 4 Fedora Update System 2017-11-07 05:10:42 UTC
libffado-2.3.0-7.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-afe600fd53

Comment 5 Merlin Mathesius 2017-11-07 14:21:04 UTC
That's great! Thank you for the prompt fix/workaround.

Comment 6 Fedora Update System 2017-11-07 19:14:39 UTC
libffado-2.3.0-7.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-afe600fd53

Comment 7 Fedora Update System 2017-11-14 00:55:33 UTC
libffado-2.3.0-7.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-11-14 09:23:32 UTC
libffado-2.3.0-7.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.