Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509473 - Installing 3.6 tried to pull 3.7 metrics images
Summary: Installing 3.6 tried to pull 3.7 metrics images
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.6.z
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-03 21:08 UTC by Eric Jones
Modified: 2017-11-29 17:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 17:12:36 UTC


Attachments (Terms of Use)

Description Eric Jones 2017-11-03 21:08:24 UTC
Description of problem:
Brand new install succeeded but the metrics pods all failed. After closer inspection we found that it was because the RCs were trying to pull the v3.7 images (these do not exist) therefore it failed. Changing the RC image line to v3.6 corrected the issue immediately and metrics worked without issue.

Version-Release number of the following components:
# rpm -qa | grep -ie openshift -ie ansible -ie ocp -ie ose
ansible-2.3.2.0-2.el7.noarch
atomic-openshift-node-3.6.173.0.21-1.git.0.f95b0e7.el7.x86_64
atomic-openshift-docker-excluder-3.6.173.0.21-1.git.0.f95b0e7.el7.noarch
tuned-profiles-atomic-openshift-node-3.6.173.0.21-1.git.0.f95b0e7.el7.x86_64
atomic-openshift-clients-3.6.173.0.21-1.git.0.f95b0e7.el7.x86_64
atomic-openshift-excluder-3.6.173.0.21-1.git.0.f95b0e7.el7.noarch
atomic-openshift-sdn-ovs-3.6.173.0.21-1.git.0.f95b0e7.el7.x86_64
procps-ng-3.3.10-16.el7.x86_64
atomic-openshift-3.6.173.0.21-1.git.0.f95b0e7.el7.x86_64
atomic-openshift-master-3.6.173.0.21-1.git.0.f95b0e7.el7.x86_64


Additional info:
Hosts file seems perfectly fine, with no reference to 3.7

Comment 1 Scott Dodson 2017-11-06 03:05:29 UTC
Eric,

I checked in the case and I don't see any reference to the openshift-ansible rpm version there either. Are we sure they're using openshift-ansible from our RPMs or have they by chance cloned it from github master branch?

Here you can see that openshift-ansible-3.6.173.0.21-1 uses 'v3.6'

$ git grep '3\.' openshift-ansible-3.6.173.0.21-1 roles/openshift_metrics/ roles/openshift_logging/
openshift-ansible-3.6.173.0.21-1:roles/openshift_logging/vars/openshift-enterprise.yml:__openshift_logging_image_version: "{{ openshift_hosted_logging_deployer_version | default ('v3.6') }}"
openshift-ansible-3.6.173.0.21-1:roles/openshift_metrics/vars/openshift-enterprise.yml:__openshift_metrics_image_version: "{{ openshift_hosted_metrics_deployer_version | default ('v3.6') }}"

Whereas master users 'v3.7', so I suspect they're working from a github checkout of master branch.

They should be able to recover by editing the deployment configs and setting the image tag to 'v3.6'

Comment 2 Eric Jones 2017-11-29 17:12:36 UTC
Apologies for the delay Scott.

Customer confirmed they pulled from github. Closing notabug


Note You need to log in before you can comment on or make changes to this bug.