Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509428 - mariadb-connector-c and mariadb-connector-c-devel have a file ownership conflict
Summary: mariadb-connector-c and mariadb-connector-c-devel have a file ownership conflict
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-03 18:20 UTC by George R. Goffe
Modified: 2017-11-27 20:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-26 08:12:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1423254 None None None Never
Red Hat Bugzilla 1494076 None None None Never

Internal Links: 1423254 1494076

Description George R. Goffe 2017-11-03 18:20:03 UTC
Description of problem:

Attempting to upgrade this system gives the following messages: 

Error: Transaction check error:
  file /usr/lib64/mariadb from install of mariadb-connector-c-3.0.2-18.fc28.x86_64 conflicts with file from package mariadb-connector-c-devel-3.0.2-11.fc28.x86_64


Version-Release number of selected component (if applicable):
see above

How reproducible:
readily

Steps to Reproduce:
1.dnf -y --best upgrade
2.
3.

Actual results:
see above

Expected results:
clean upgrade

Additional info:

Comment 1 Michal Schorm 2017-11-13 13:38:35 UTC
Can zou please test this update?:
https://bodhi.fedoraproject.org/updates/FEDORA-2017-218151e030

I believe it is meant to fix exactly your issue.

Comment 2 George R. Goffe 2017-11-13 17:21:08 UTC
Michal,

I believe this problem is resolved. "my" system has been thinking that it's a Fedora 28 (Rawhide) system for a few weeks now... 

Here's the status of this connector:

rpm -q mariadb-connector-c
mariadb-connector-c-3.0.2-19.fc28.x86_64

Thanks a LOT for your help and hard work,

Regards,

George...

Comment 3 Michal Schorm 2017-11-13 23:39:42 UTC
Glad to hear it is not a problem anymore :)

Comment 4 George R. Goffe 2017-11-24 17:03:32 UTC
Hi,

This just in from Fedora 28 (rawhide)... Sigh...

George...

Error: 
 Problem 1: cannot install both mariadb-connector-c-3.0.2-20.fc28.x86_64 and mariadb-connector-c-3.0.2-19.fc28.x86_64
  - package cherokee-1.2.104-1.fc25.x86_64 requires libmysqlclient.so.18()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package mariadb-connector-c-3.0.2-19.fc28.x86_64
  - cannot install the best update candidate for package cherokee-1.2.104-1.fc25.x86_64
 Problem 2: problem with installed package cherokee-1.2.104-1.fc25.x86_64
  - package cherokee-1.2.104-1.fc25.x86_64 requires libmysqlclient.so.18()(64bit), but none of the providers can be installed
  - cannot install both mariadb-connector-c-3.0.2-20.fc28.x86_64 and mariadb-connector-c-3.0.2-19.fc28.x86_64
  - mariadb-connector-c-3.0.2-20.fc28.i686 has inferior architecture
  - package mariadb-connector-c-devel-3.0.2-20.fc28.x86_64 requires mariadb-connector-c = 3.0.2-20.fc28, but none of the providers can be installed
  - cannot install the best update candidate for package mariadb-connector-c-devel-3.0.2-19.fc28.x86_64

Comment 5 Pavel Raiskup 2017-11-26 08:12:43 UTC
George, your package 'cherokee-1.2.104-1.fc25.x86_64' is broken.  Please
follow bug 1423254 and bug 1494076.  Solution is to remove that package
for now, and urgue cherokee's maintainer.

Comment 6 George R. Goffe 2017-11-26 20:03:55 UTC
Pavel,

Thank you for this information. I'll be removing Cherokee in a few mins from ALL my systems.

Regards and again, thanks,

George...

Comment 7 Anton Guda 2017-11-26 20:28:05 UTC
I observed this bug during update due to old symlink mariadb->mysql in _libdir.

Comment 8 Pavel Raiskup 2017-11-27 20:45:22 UTC
(In reply to Anton Guda from comment #7)
> I observed this bug during update due to old symlink mariadb->mysql in
> _libdir.

I believe that this issue in particular has been fixed (commit af8dcf6e).


Note You need to log in before you can comment on or make changes to this bug.