Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509318 - [UPSTREAM] VM Search not filtering VMs correctly under /vm_infra/explorer
Summary: [UPSTREAM] VM Search not filtering VMs correctly under /vm_infra/explorer
Keywords:
Status: CLOSED DUPLICATE of bug 1517392
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.9.0
Assignee: Hilda Stastna
QA Contact: Kedar Kulkarni
URL:
Whiteboard:
Depends On: 1497278
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-03 14:18 UTC by Satoe Imaishi
Modified: 2017-12-04 10:09 UTC (History)
9 users (show)

Fixed In Version: 5.9.0.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1497278
Environment:
Last Closed: 2017-12-04 10:09:54 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
search filter not applied (deleted)
2017-11-10 17:47 UTC, Mike Shriver
no flags Details

Comment 3 Mike Shriver 2017-11-10 17:47:49 UTC
Created attachment 1350612 [details]
search filter not applied

The screenshot also shows ec2 instances in a view filtered for rhv provider, this was recorded in BZ 1512030

In the 5.9.0.8 build I am seeing a failure to apply search parameters in infrastructure VM views

Comment 4 Mike Shriver 2017-11-10 17:49:30 UTC
Moving back to ON_DEV, see attachment 1350612 [details] in comment 3

Hilda, can you confirm that the behavior is still present?

Comment 6 Hilda Stastna 2017-11-24 14:33:17 UTC
This bug is not present, not in 5.9. and also not in master. I am closing the bug.

Comment 8 CFME Bot 2017-11-29 20:32:44 UTC
New commit detected on ManageIQ/manageiq-ui-classic/gaprindashvili:
https://github.com/ManageIQ/manageiq-ui-classic/commit/e9b01a77b82f1b71241bc2c3f34d1691f7ae9874

commit e9b01a77b82f1b71241bc2c3f34d1691f7ae9874
Author:     Milan Zázrivec <mzazrivec@redhat.com>
AuthorDate: Tue Oct 31 10:46:39 2017 +0100
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Mon Nov 6 14:17:34 2017 -0500

    Merge pull request #2556 from hstastna/VM_Search_filtering_VMs_explorer
    
    Fix Search to filter VMs
    (cherry picked from commit e7c322b5d43bb1ba3575208f298e27158d49971b)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1509318

 app/controllers/application_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 9 Hilda Stastna 2017-12-04 10:09:54 UTC

*** This bug has been marked as a duplicate of bug 1517392 ***


Note You need to log in before you can comment on or make changes to this bug.