Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1509 - breaks on 2.2 kernels
Summary: breaks on 2.2 kernels
Keywords:
Status: CLOSED DUPLICATE of bug 1225
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: psacct
Version: 5.2
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-14 13:47 UTC by Chris Ricker
Modified: 2015-05-08 19:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-14 19:35:32 UTC


Attachments (Terms of Use)

Description Chris Ricker 1999-03-14 13:47:13 UTC
psacct needs to be updated for 2.2 kernels.  However,
the caveat is that the autoconf script for it is broken.
After doing a ./configure, the config.h looks like:

/* Define if you have the <linux/acct.h> header file. */
/* #undef HAVE_LINUX_ACCT_H */

instead of the necessary

/* Define if you have the <linux/acct.h> header file. */
#define HAVE_LINUX_ACCT_H

so, in addition to recompiling against 2.2 headers, you'll
also either need to patch the autoconf stuff or else add
a kludge to sed the config.h after it's generated.

Ask away if you have more questions.  BTW, I'm assuming
this is true for all architectures; I've only noticed it
on i386, but because of why it broke, it should be true
on everything.

later,
chris

Comment 1 Jeff Johnson 1999-03-14 19:35:59 UTC
*** This bug has been marked as a duplicate of 1225 ***

Comment 2 openshift-github-bot 2015-05-08 19:02:08 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/fefdf65261b6035a25f77bba51eee820c80ca2e2
Issue 1509 - fix usage error in openshift start


Note You need to log in before you can comment on or make changes to this bug.