Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1508465 - With RHV Graph refresh template numbers in Provider inventory does not get updated correctly.
Summary: With RHV Graph refresh template numbers in Provider inventory does not get up...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.10.0
Assignee: Piotr Kliczewski
QA Contact: Angelina Nikiforova
URL:
Whiteboard: rhev:graph refresh
Depends On:
Blocks: 1532255 1510499
TreeView+ depends on / blocked
 
Reported: 2017-11-01 13:39 UTC by Ilanit Stein
Modified: 2019-04-02 08:24 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1510499 (view as bug list)
Environment:
Last Closed: 2019-02-11 13:55:43 UTC
Category: Bug
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)
evm.log (deleted)
2017-11-01 13:47 UTC, Ilanit Stein
no flags Details
rhevm.log (deleted)
2017-11-01 13:47 UTC, Ilanit Stein
no flags Details
automation.log (deleted)
2017-11-01 13:48 UTC, Ilanit Stein
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq-providers-ovirt pull 129 None None None 2017-11-03 15:14:04 UTC
Github ManageIQ manageiq-providers-ovirt pull 203 None None None 2018-02-14 11:24:50 UTC

Description Ilanit Stein 2017-11-01 13:39:56 UTC
Description of problem:
There seem to be several problems seen in the Provider details page:
1. "Hosts & Clusters", "Vms & Templates" fields are not populated: Contain 'N/A'
2. Templates number do not get updated, though several templates were added on the RHV side, and though a target refresh was triggered, on CFME side.

While on CFME, from same version, without the RHV Graph refresh ON,
1. "Hosts & Clusters", "Vms & Templates" fields contain: Available.
2. Templates number gets updated, further to several templates were added,
on the RHV side.

 
Version-Release number of selected component (if applicable):
CFME-5.9.0.4 + Graph refresh for RHV turned ON
RHV-4.1.6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Ilanit Stein 2017-11-01 13:47:14 UTC
Created attachment 1346541 [details]
evm.log

Notice templates 1_test, 2_test that were added, however number of template did not increase in the Provider details page, on "Templates" Field.

Comment 4 Ilanit Stein 2017-11-01 13:47:49 UTC
Created attachment 1346542 [details]
rhevm.log

Comment 5 Ilanit Stein 2017-11-01 13:48:27 UTC
Created attachment 1346544 [details]
automation.log

Comment 7 Piotr Kliczewski 2017-11-03 15:14:05 UTC
I analyzed the logs and noticed two issues. One related to graph refresh and fixed by PR 129. The other seems not related and was handled by Juan here [1].

I was not able to reproduce the issue in my env.

[1] https://github.com/ManageIQ/manageiq-providers-ovirt/pull/128

Comment 10 Boriso 2018-02-14 11:22:52 UTC
this was fixed by:
https://github.com/ManageIQ/manageiq-providers-ovirt/pull/203

Comment 11 Ilanit Stein 2018-09-17 13:22:31 UTC
Verified on CFME-5.10.0.15/RHV-4.2.3.

On CFME, RHv provider details page:
1. "Hosts & Clusters", "Vms & Templates" fields contain: Available.
2. Templates number gets updated, further to several templates that are added,
on the RHV side.


Note You need to log in before you can comment on or make changes to this bug.