Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 150747 - X11 memory leak related to cursor theme?
Summary: X11 memory leak related to cursor theme?
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL: http://sourceforge.net/tracker/index....
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-03-10 04:49 UTC by Kyle Bateman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 21:27:47 UTC


Attachments (Terms of Use)
Demonstration program (deleted)
2005-03-10 04:50 UTC, Kyle Bateman
no flags Details
Another test case (deleted)
2005-03-10 04:50 UTC, Kyle Bateman
no flags Details

Description Kyle Bateman 2005-03-10 04:49:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
This is a memory leak in X11.  I report it here, because the bug report thread indicates that it only happens with certain cursor themes installed.  I'm not sure how to verify whether this bug goes away if the bluecurve cursors are disabled and X11 is run with its native cursors, but that would be a good test.

The other (earlier) bug thread is at:
http://sourceforge.net/tracker/index.php?func=detail&aid=918052&group_id=12997&atid=112997

This contains more helpful information.

I'll upload one of my test scripts which shows X11 leak in a way that does seems to yield irretrievably allocated memory.

Version-Release number of selected component (if applicable):
redhat-artwork-0.117

How reproducible:
Always

Steps to Reproduce:
1.Start with a fresh launch of X11
2.Run the included script
3.Press the Reload button once (or hold for multiple presses)
4.Watch the X server grow
5.Terminate the script
  

Actual Results:  The X server process continues to grow with each press of the Reload button.  It never shrinks--even after the application exits.

Expected Results:  There is no reason X should grow at all since all we are doing is setting a cursor.  In any event, the system should reclaim memory after the application exits.


Additional info:

I'll also post an extremely simple script (membug2) which also shows the problem.  With this example, run "membug 500" to see X grow and stay large.  Then run "membug 10" to see it shrink back down again.  In any case, X should not grow at all simply by resizing the cursor.

This causes certain of my workstations to reliably crash after several days of service.  I have a limited number of times the user can see his cursor change before his system blows up.

Comment 1 Kyle Bateman 2005-03-10 04:50:20 UTC
Created attachment 111841 [details]
Demonstration program

Comment 2 Kyle Bateman 2005-03-10 04:50:53 UTC
Created attachment 111842 [details]
Another test case

Comment 3 Kyle Bateman 2005-03-15 05:03:41 UTC
OK, I can verify that if the Xcursor extension is not used, this memory leak
goes away.  I did:

cd /usr/share/icons/default
mv index.theme index.theme.save
Ctrl-Alt-Bksp

My cursors revert to native X11, and none of the demo programs produce leaking X
server anymore.  I've tried a number of different cursor themes (about 5) and
they all seem to leak just the same as BlueCurve.  Disabling the extension seems
to be the only workaround.

Comment 4 John (J5) Palmieri 2005-03-22 23:46:57 UTC
Reassigning to xorg

Comment 5 Mike A. Harris 2005-04-11 09:43:42 UTC
Please report this problem via the X.org bugzilla located at:

    http://bugs.freedesktop.org - in the "xorg" component

Once you have filed your bug report in X.org bugzilla, please paste the
URL here and we will track this issue in the X.Org bugzilla, and review
any fixes that become available for consideration in future Fedora Core
updates.

Comment 6 Mike A. Harris 2005-04-11 09:47:42 UTC
Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.

Comment 7 Mike A. Harris 2005-05-16 21:27:47 UTC
2 months have elapsed since the last feedback from this issue, and there
has not been any feedback to my request in comment #5 to report the issue
to X.Org, so I assume the problem is either not a bug in X.Org supplied
software, or that the issue is resolved in the current updates released
for Fedora Core 3.

If this problem still exists however, follow the instructions in comment
#5 above, and we will track the issue in X.Org bugzilla as indicated.

Setting status to "RAWHIDE"

Comment 8 Kyle Bateman 2005-05-24 18:01:19 UTC
Posted to freedesktop.org as:

https://bugs.freedesktop.org/show_bug.cgi?id=2731

Comment 9 Mike A. Harris 2005-05-26 02:17:02 UTC
Thanks for the URL.  Changing status to "UPSTREAM" for tracking.


Note You need to log in before you can comment on or make changes to this bug.